Read-only workaround

O, wow. It seems that I found a very interesting workaround for Anytype read-only files limitation. I think it may be usefull to some, as multiple people asked about ability to edit files stored/linked to Anytype.

I wanted to be able to insert .docx files into Anytype in a way that allows for editing them. I want to have a clear list of “all the document I’m working on right now”. The problem was - if you upload a file into Anytype, it becomes read-only. If I wanted to work on a file stored on Anytype, I would have to upload it every time, I make any changes.

BUT you can create a link to a file path (file:///) and as long as the file path doesn’t changes, the link keeps working. So I can create a local file, place it somewhere I intent it to stay and then create a link on Anytype. Then I can access the file directly from Anytype, without having to use windows explorer to find the file.

It works only on single device, but still, until we get a option to edit stored files (or to create links to local files directly from Anytype) this workaround opens new ways for local file management.

First, I tried to use .lnk files but after couple of tries, I managed to make file path links work as well. .lnk files still seem to be an only option if file path uses non-english symbols.

4 Likes

Hi @boring_Pete, thanks for sharing this workaround! Until a file system integration is there, this is definitely a usable workaround for me :slight_smile: .

1 Like

Can one of you guys link me to the bug report on this one? Thanks

@Angelo there is no bug report, but there are these requests/discussions:

1 Like

Did not know file:/// worked! It also works with folder paths, so possibly that’s a way to get around changing file names (link to the folder of a project instead of to the latest file).

Should the menu reflect that then? Currently when I attempt to add a link it says “Web sites” (which is why I didn’t think file:/// would work). Should it be “Web/local links” or something?

Edit:

  • Actually I just pasted a local file link (C:/projects), without the file:///
  • Would be good to be able to edit the link afterwards. Currently it doesn’t seem to be possible?
  • Would also be good to be able to disable the little icon (below), so it looks just like any other hyperlink

image

Related post I did a while back:

1 Like