Modal for "Edit link" locates at the top left corner

WHAT IS THE BUG

When hovering over a text link (URL website) and clicking the “Edit link” button, the modal for editing link jumps to the top left conner, even gets covered by the Red, Yellow and Green Window Buttons.

HOW TO REPRODUCE IT

  1. Create a text link for website (url).
  2. Type multi-line text to make sure can scroll down the page.
  3. Scroll down the page a little.
  4. Hover over the text link and click “Edit link”
  5. Can see the modal shows at the top left corner, and is covered by red, yellow and green button.

This video shows three cases.

  1. Not scroll down the page: modal stays at corner and not get covered.
  2. Scroll down the page: modal stays at corner and get covered.
  3. Occasionally: modal stays near the text link. (shows at the corner first and jumps to correct place very quickly, as shown in the video 00:00:03 – 00:00:08)

THE EXPECTED BEHAVIOR

Make the modal stays near the chosen text. At least make it not be covered by the three Window Buttons.

SYSTEM INFORMATIONS

  • OS:
    macOS 13
  • Device:
    MacBook Pro 2020
  • Anytype Version:
    0.29.1

ADDITIONAL CONTEXT

I’m not sure whether this is an accident issue or a stably reproducible one. I remember the modal was near the text before, but it fails now, even after reopening Anytype. There came a time that the modal shows near the text correctly but then jumps to the corner very quickly. Sometimes it works well, and I capture one in the video fortunately.

What’s more, a bug I posted before is also relative with scrolling down a page. Maybe they have the same essential problem. I guess.

https://community.anytype.io/t/view-of-page-moves-after-indenting-a-block/7766

1 Like

Can confirm this bug on Linux.

This issue has been added to our issue tracker and was received by the Development Team.

This issue has been fixed by the Development Team and will be included in an upcoming release.