Sync slow and requires restart of the client

Describe the bug
Sync is very slow and when it is done syncing changes are not show. Ones you restart the (desktop) app completly you can see the new objects/blocks. Sometimes it requires more then one restart (or syncing is very, very slow).

To Reproduce
Steps to reproduce the behavior:

  1. Create new objects, pages or blocks
  2. Let it sync and shut down anytype
  3. Open anytype on another PC
  4. Wait for the sync status in the top right to turn green and say Synced
  5. Look for the new objects, pages or blocks that where just created, they will not show
  6. Restart the app, now look again, they should be visible
  7. Repeat restart if needed

Expected behavior
Ones Anytype syncing status turns green and shows synced, one would expect all the changes made on other devises/PC’s to then be visible and not require a restart.

If this is working as intended, there should be a popup ones synced that says, restart to view changes (or something).

System Information:

  • OS: Android 10
  • Anytype Version: 0.20.9

Additional context

3 Likes

@Jeroen Hi! Does it work the same way for you in the newest anytype versions?

I think it is fixed yes.

As said in another topic a bugged page could now be removed and deleted and on both my second laptop as well as my android phone that bugged page was also removed on first startup! Awesome work.

If I ever experience this again I will reply to this topic :wink:

1 Like

Syncing between devices (android 0.5.0 version and windows 0.23.0) is very slow at the moment and even erases some of my stuff. For example, I wrote a text 20 blocks on PC. A few minutes later 4 blocks arrived at my android version. And another few minutes later the 4 blocks were synced with my windows version and deleted the other 16 blocks.

2 Likes

I don’t know why but for the last 3 days sync is again nog working…

Made a new Lego Set at my laptop, on the same network of my desktop and it just doesn’t sync… Can’t see the Lego pages on my desktop.

Bugs like this are really killing the fun of Anytype for me … :frowning:

@Jeroen there was some hiccup with high system utilisation on our end the team is working to fix resource cpu utilisation and outgoing packets on the backup node which are affecting the sync. there has been a temporary fix and the permanent fix is incoming

1 Like

A quick question about this fix. Do I need to do something on my end for this fix to work? As of today, I still haven’t got my Lego pages on my desktop hehe. While it is now synced on my phone.

Pages where made on my laptop.

Update;

Past weekend I deleted te data2 folder and my precious Lego pages are now synced.

So I fixed it that way but that should not be intentional I hope.

Also, the data folder was huge (over 4GB), after sync it was only a few hundred MB’s. Just a side note.

I’m also running into this problem. Only now even restarting isn’t fixing the problem. I can’t sync between desktop, android and the server. It’s been 3 days since the last sync now. It’s completely unusable.

I lost all my work from the last 8 days because it didn’t sync on windows… After a fresh install I saw that all the work was gone and the last change in object history was 8 days ago. Even though I worked daily for over an hour Anytype didn’t synced my stuff for 8 days…

1 Like

I will report this to our team with high priority. Thank you for notifying!
Can you please provide us with more information completing this guide: Sync problems, White screen or not responding, high resource consumption - #5 by Vova

After a long time just doing one-off tests I decided to try out using Anytype for my actual notes. My plan was to keep it simple, and only create Note types, and seeing them via a Set.

Unfortunately I found that sync is very slow/unreliable. It seems to always work, but hard to tell when the update will happen.

Worse part of it (for me) is the lack of accurate feedback (Sync status on the top always shows Synced - green dot) and inability to force Sync (by swiping down, for example).

This post is marked as Solved. Shall we unmark, or create a new one?

I agree we should mark it as unsolved if (some) users still or again experience this issue.