Problems when moving blocks in a page with columns

Describe the bug
Problem 1: Moving a block to a single column over two is extremely hard (but possible)
Problem 2: Moving a block to a column forces the last indentation (“Block 3.1” instead of “Block 3”)
(Watch the video for clarity)

To Reproduce
Steps to reproduce the behavior: (video)

Expected behavior
Problem 1: Should be easier to move the full column over the other two.
Problem 2: Should be possible to add the block 3 directly without the indentation.

System Information:

  • OS: e.g. Windows 10/11
  • Anytype Version: 0.27.0

Additional context
Related to: A comprehensive anytype first impression
May be related to some other bug.

P.s. sorry I forgot to remove the mic input from OBS

In case you don’t know. You are also uploading audio in your video.

Regarding the video. Maybe the UI is not showing it enough. But it is pretty easy to place a block between column B and C. But the indicator is shown on the right side of column B, not on the left side of column C, where you tried to drop it.

Yeah sorry about that I didn’t notice the audio line was on.

About the bug I’m sorry if it wasn’t clear but this is a bit hard to explain:
Problem 1: I wanted to move the “full column A” over the other two, and this is possible but extremely hard because the margin to to that is incredibly thin.
Problem 2: I wanted to move the block 3 into the Column A without the indentation, which is not possible if the Column B has not a “block 3”

Thats right. Seems to be a problem, when the moved block is positioned as the first block.
Moving it over another (not the first) block, is more easy.

Of course this should be adjusted to also be easier when placed as the first block.

1 Like

I’m not sure if I get that right. Isn’t that what you did in your video?


Yes, and you can see that moving the red block 3 how I later did with the green one is not possible, which is what I wanted to do. If it’s still not super clear I can do a video on how it works in Notion.

It should work fine in next release


This topic was automatically closed after 2 days. New replies are no longer allowed.

Looks like only the “problem 1” is solved.
Here is another take on “problem 2”:

p.s. sorry about the audio, forgot to mute the mic from obs

Replicated the “problem 2” on Windows 10 / Anytype 0.31.0

This report has been added to our issue tracker and received by the Development Team.

@kerbless can you try to replicate in latest Nightly Version and make a new bug report about problem 2, if necessary. :v:

Replicated on Version: 0.31.1-beta (windows 11), the bug is identical, do I need to make a new report?

1 Like

Not in this case, we have updated the issue.
But going forward, always confirm it on current Nightly Version.

1 Like