Linux version does not "keep me logged in"

Hi! I’m not sure if this belongs here, but I’ll try:
I use Anytype on multiple devices (2 Windows computers, 2 Linux computers & 2 Android devices).
Every time I open the Anytype appimage file on Linux, I need to login.
I don’t know if this behavior is intended.
The last time I didn’t even noticed I was screen sharing and exposed my keychain phrase…

To Reproduce
Steps to reproduce the behavior:

  1. Open Anytype
  2. Login
  3. Close Anytype
  4. Reopen Anytype
  5. You need to login again

Expected behavior
Like on other platforms, I would continue to be logged in (or at least set the keychain as a password field)

System Information:

  • OS: Arch Linux
  • Device Manufacturer/Model: Any Linux laptop
  • Anytype Version: 0.23.5

Kindly install gnome-keyring or use KeepassXC. Anytype uses Secret service to store the passphrase so you need something that implements Secret Service API


use KeepassXC

I already use Bitwarden and it hasn’t been an issue so far.
The complaint mostly came from the fact that the secret is not hidden

Anytype uses Secret service to store the passphrase so you need something that implements Secret Service API

I thought the KDE Wallet would have been just fine :c

install gnome-keyring

And that solved the issue!

I had the same issue on Anytype 0.24.0 on OpenSUSE Tumbleweed 20220304, and was able to fix it by installing gnome-keyring. For future versions of Anytype, I would definitely like to be able to use KDE Wallet instead in the future as that’s my main DE.

Can KeepassXC still be used for this if it’s the flatpak version? @lynxlove

kwallet’s support for libsecrets is yet to be approved and merged. Once it is released, kwallet can be used as a secrets provider instead of gnome-keyring or keepassXC

I’ve never tried it myself, so I’m not entirely sure. But it should work

Sorry for bringing up again this topic but I’m using the AppImage version on Arch and I can’t seem to stay logged in even with gnome-keyring installed. Is there any other requirement or am I missing something else?
(p.s. I gave a quick look at What are Linux keyring, gnome-keyring, Secret Service, D-Bus but I’m not confident in this field yet)

1 Like

install libsecret, keyring does not install libsecret somehow, at least this is what I’ve read


I have installed:

libsecret 0.20.5-2
gnome-keyring 1:42.1-2
archlinux-keyring 20230130-1

but closing and reopening the app asks for the credentials again, could it be something related to the fact that I’m not using a desktop manager?

I still have this problem on Arch Linux / Anytype Version: 0.32.9-beta

I have the same problem that @kerbless in Kubuntu 18.04.6 LTS. I installed libsecret and gnome-keyring and the app (v0.35.2) does not keep the login after reboot.

1 Like

@kerbless @hlfernandez
Can you please confirm this on 0.36.0 before we send it to the devs?

I had this problem for a few days recently with AppImage after updating to 0.36.5-alpha when 0.36.5-alpha was released. It was enough for Anytype window to run in the background for a few minutes to log me out. I had to downgrade to 0.36.2-alpha-win7 (still the same, even if previously there was no problem with 0.36.2-alpha-win7), and then to 0.36.0 (where it stopped, IIRC). But the next day, 0.36.5 kept me logged in again, and I had no issues using 0.36.5 since.

I am not sure if the downgrade was what finally helped, or if it has simply taken some time (like a day or so) for something on a server to sync or similar.