Cannot delete objects

Describe the bug
I was really testing out the delete feature and not sure how I ended up in this state unfortunately.

To Reproduce
Steps to reproduce the behavior:

  1. Go to any object and move to bin
  2. Go to Bin to permanently delete

Most objects I am able to delete but these 2 I cannot.

image

Expected behavior
I expect objects to be deleted.

System Information:

  • OS: Windows 10
  • Anytype Version: 0.21.1

Additional context
I actually went a little crazy and tried to delete everything I had created in the previous version before delete was introduced. I was able to delete my profile even. Is it possible to reset my account? I put my anytype id in the topic for removing all data, but not sure it will be done.

Cheers

I have a potentially less radical solution for you.

  1. Use the Graph view to identify possible forgotten Objects and delete them one by one
  2. Then empty your entire bin
  3. Then close Anytype
  4. Uninstall Anytype from your Windows settings
  5. Then delete your “anytype2” folder located under:
    C:\Users\ YOUR USER NAME \AppData\Roaming
  6. Then reinstall Anytype and login

I tested this procedure to initially realize the process of reinstallation, and to my surprise it reset some missing objects and better than that, it deleted the Relationships that were unused.
I’m back to a clean slate.

So it may help you too :grinning_face_with_smiling_eyes:

1 Like

Hello!

Thanks for the tip!
It almost worked, I have one page I cannot delete but I guess I will live with this for now. Everything else is reset.
image

If anyone from the dev team has other suggestions, I am all ears.

Cheers

I’m glad it helps.
Worth try to redo the whole process a second time, oddly it may help with that residual object.

1 Like

Haha I did exactly that just now and voila, works great! I am reset!

1 Like