Bugs in text selection across blocks using shift+up/down

Edit by @sambouwer:
The original issue below was resolved, but the following issues are persistent in Anytype for Windows 0.24.0:

  • Text in blocks cannot be selected with Shift + Down if the cursor is not at the very beginning of the block
  • Only after first using Shift + Up to select the block above you can use Shift + Down to select the active block and blocks underneath it.

Original post:

Selection seems to always stop whenever there are nested blocks.

For example, if I have the cursor in the top block here:

And I press SHIFT+DOWN to select the blocks below, it stops here:

Interestingly, starting the selection on a child block allows selecting more blocks below it, even outside the original parent (which seems useful btw).

1 Like

This seems to be fixed in the current releases.

Hm weird. I just tried it out and now SHIFT + :arrow_down: doesn’t even select the blocks below (regardless if nested or not).

It’s not consistent either. From 10 attempts, twice it worked (in different Pages). Weird…

I removed the Solved for now while we troubleshoot this!

Edit: I have the newest version installed btw. Windows

1 Like

Hi @qualquertipo could you please record a video/screencap of the issue? I cannot reproduce this on Anytype for Windows 0.24.0. I’ve tried the steps below with an Page object with only Text blocks, and also with two Text blocks nested under another Text block like you have in your example:

Will do.

Did you try with multiline blocks?

Nope, I will try that too!

Edit: multiline (with Shift + Return) works fine for me.

I placed the cursor before the bold “Test”, held SHIFT and kept pressing DOWN. The selection stops there.

(What’s the easiest way to capture/post video like you did? I’m on Windows)

I used a tool from the Microsoft Store as it allows you to record only a single window:

Could you include how you typed the text?

I typed Test then copy pasted it a few times. But I just tested typing a few lines directly and the same happens…

Here’s a GIF of it (first I create the text, then I attempt to SHIFT+DOWN to select blocks):

fff2

Thanks for the recording! I’m trying to reproduce:

Only singe words (“Test”), each in a new block. Tested but not recorded: Nesting blocks have no impact on the behavior that I tested below.

Ok, I think you narrowed it down then.

Selecting across blocks works only if the cursor is at the beginning of the block. Also, it depends on how the cursor got there! It seems it the selection doesn’t work when placing it with mouse/pointer, but it does when moving the cursor in using keyboard (coming from a different block).

Anyway, I guess the original bug is solved. Should we create a new bug report for the inconsistent behaviour selecting across blocks?

PS: not directly related, but I also have this FR on selection/blocks:

I’m not sure whether it would be better to repurpose this topic to address the other issues, too, or mark this one solved and continue in another one.

Maybe we make the topic title a bit more generic and keep using this topic to address text selection issues?

Agree to repurpose it. However I don’t seem to be able to edit my own post… Maybe because it’s old.

I can’t seem to reproduce the issue you mention with the difference between the functionality when using the mouse to place the cursor vs using the keyboard to place the cursor. For me the behavior is all the same (although not as we want :wink: )