You have another instance of Anytype running

Description
After a crash (for unknown reasons, computer was in sleep mode), Anytype believes there is another instance of Anytype running and produces an error message at startup. It says “Closing…” but does not close any other process that may be running. There is no obvious signs another process is running to the average user.

Reported previously in 2022 but closed.

image

The renderer helper process was running in the background and needed to be force-quit. (Seems it did not stop running since the program crashed).

To Reproduce
Steps to reproduce the behavior:

  1. A crash may be necessary, or some sort of unexpected quit
  2. Attempt to open Anytype
  3. Anytype will close itself…
  4. Activity monitor may indicate a background process is still running

Expected behavior
Perhaps Anytype could attempt to determine whether an actual usable process is open, and force-close the background process if not.

System Information:

  • OS: Mac OS X Ventura (ver. 13.1)
  • Device Manufacturer/Model: Apple MacBook Air (Intel QuadCore i5, 2020)
  • Anytype Version: 0.31.0 mac-x64
2 Likes

Welcome to the Community @wilson71 and thank you, this is literally a text book bug report.

First, you did your due diligence and found a similar (closed) report, you followed all the rules of the template, filled it out cleanly with thorough and clear conveyance, and the chef’s kiss…provided screen shots. All on your own accord.

Exquisite :pinched_fingers: :rose:


It’s with great pleasure that I can confirm:
this report has been added to our issue tracker and received by the Development Team.

1 Like

This issue has been fixed by the Development Team and will be implemented in an upcoming release.

Hey, I just updated to version 0.32 and have the same issue on the Appimage. Supposedly I successfully imported content from Notion, after not seeing the content I quit the program and attempted to open again.
I also check top and have no process running after it closes.

To Reproduce

Steps to reproduce the behavior:

  1. Select import content from notion
  2. Quit the app after import
  3. Open Anytype
  4. Anytype will show an error
  5. App will ask to log-in again
  6. After log-in app will show the message “You have another instance of Anytype running” and close it self after clicking OK
  7. System Monitor will show no AnyType service running
    image

Expected behavior
Successful log-in

System Information:
image

  • Anytype Version: Anytype-0.32.0.AppImage
1 Like

@Angelo I’ve put this back from Next Release to Triage as this is still happening on 0.32.0 (beta). Could you update the relevant Linear topic?

Still happening on 0.32.3

The issue isn’t happening on the same system running Windows 11

Edition Windows 11 Pro
Version 22H2
Installed on ‎29/‎04/‎2023
OS build 22621.1848
Experience Windows Feature Experience Pack 1000.22642.1000.0
1 Like

Still on 0.34.3

Is there a suggested workaround? A lock file that can be manually removed for now?

I’m thinking the system keyring but haven’t test it yet

It works on a freshly installed OS

1 Like