What happens if it doesn't recognize my pin code?

WHAT IS THE BUG

I tried to login, on the desktop app, and I enter the pin code but it doesn’t recognize it. I always save my passwords and pins on Lastpass, immediately after i enter them, so I am pretty sure I have entered the correct pin. But, the system says it is incorrect pin. so… delete and recreate the account? Can’t I restore it somehow whit the phrase?

HOW TO REPRODUCE IT

  1. Go to…
  2. Click on…
  3. Scroll down to…
  4. See an error.
  5. I was able to provide you a video capture of the bug, here it is:

THE EXPECTED BEHAVIOR

After pressing Login, I type the phrase and then I get the Enter Your PIN CODE window. I ENTER the 6 digits of my PIN CODE and I get the Error that my PIN is incorrect.

SYSTEM INFORMATION

  • OS:
    ᅟWindows 11 Pro, build 22621
  • Device:
    HP Probook 450
  • Anytype Version:
    0.30.0

ADDITIONAL CONTEXT

If other context, people, or related Bug Reports as to be mentioned, do so right here.

Hi @Varvara, I hope you are referring to the pin that is not recognized, and not the passphrase. If you lost the passphrase you’ll need to setup a new account. If you just lost the pin, you should be able to reinstall Anytype and login with your passphrase as I believe the pin is a local configuration. I’m not 100% sure but you could give a reinstall a try.

Secondly, could you properly fill in the bug report template? I.e., remove the pencil icons, and fill all relevant sections (and remove the rest). Thanks!

1 Like

Hello Sambouwer thank you for your response.
It was indeed the PIN number. I tried a few things and I think I also tried your suggestion. I also logged out, started a new signup, entered the code and got new phrases. In all my tries, after entering the phrase, I got into the PIN which was not recognized and got the same error of : Incorrect PIN.
I ended up reinstalling the app, and creating a new account with a different email address. I haven’t enabled the PIN yet, will tried maybe at some point.

Thank you,
Varvara

1 Like