Undeletable objects

Interesting, because on my side this Object is perfectly synchronized, as much on Desktop as on Mobile. :thinking:
Thanks for your feedback, it will surely be useful for the devs.

1 Like

Until this update (0.24) I was still unable to successfully resolve this issue. At present, I have 3 pages that cannot be deleted.

1 Like

Can you confirm me that your three undeletable Objects are Page Type, or are they of different types each?

For me that’s the default Page Type for all fo them.

Yes, the file I can’t delete is the default page type (page)

Expect to fix this problem quickly, but the official staff does not seem to have noticed the problem

1 Like

For your record, the correct terminology is rather:
“I can’t delete is the default Object type (page)” because it’s all about Object in Anytype :wink:

I mentioned this bug to the staff during the last Discord session but unfortunately the audio connection was not working well enough for me to understand the core of the problem, but I need to contact someone on the forum for help on this issue.

The undeletable page can be deleted via old version of Anytype Windows desktop, for instance 0.21.0.

The page can be moved to the bin by the button in the mainpage and then deleted in bin.

If you go to the search box and open the page, it shows the object doesn’t exist.

Note that both the Android & Windows side contain local files that make the undeletable page being a ghost object that exists in the search list, sets and sidebar history even after the deletion via old version Anytype. You have to delete the android app and reinstall it to remove the undeletable page on Android, and delete the Windows software and its local files in roaming then reinstall it to solve the ghost object problem.

  • Windows: 0.24.0
  • Android: 0.6.0

Thank you for your bug investigation! Now it remains to know if the bug can still reappear after this cleaning procedure, or if this one actually solves the problem once and for all.

Well… I tried the @peach’s method with an old v0.21.1 of mine, and the bug is getting worse as those Objects became unselectable and forever loading Objects. But it brings the benefit of:

1. Reset the delete feature for every new Page Object Type.
2. Allowing to erase all the residual objects of the Graph view

I’m sorry for that. But I did delete the ‘undeletable page’ without any bugs. Have you changed back to the latest Desktop version (0.24.0) ?

No problem, for now, I only use anytype to find bugs and improvements. Your method was worth trying, and the fact that it did not have the same result for me may help the developers.

Of course I came back to the lastest version after all your steps :sweat_smile: The thing is, I didn’t do it through the In-app update system. Is that the way you did it too?

I have the same problem with a couple of objects. And also they are default Page Type. Pretty much as AyneHencer described.

In case it helps, I also noticed that the text below the name of the object (Object Type, Created by…) is aligned to center, instead of left. This can be seen in the pictures/videos shared above.

1 Like

Welcome back to the forum, thank you for this observation. I mentioned you in the description.

I also encountered this problem
Version: 0.25.0
Any newly created type cannot be deleted

@forgettable @urkan @mxxiv @jzbjing
Can you please send me your anytypeID in direct message?
We want to check all errors related to this problem in analytics

Any news on this topic? It keeps occurring after a couple of upgrades
Something else we can do to help?

1 Like

@urkan Do you mean that undeletable objects which were created in defunct versions of Anytype, continue to be undeletable after upgrading? Or that, even in the most current of Anytype, there can be newly created objects which have become undeletable? Or both?

Both. The mention to the upgrades was about it’s been a while since the topic was created. To be clear:

  • I still can’t delete the older undeleteable objects.
  • And in the current Anytype version (0.27.0) there are newly created objects that become undeleteable.

I am currently creating pages from a set (clicking “+ New”) and choosing a template, and it’s happening like 1 out of 6 times.


Hey, there!
We will investigate this issue and do our best to fix it as fast as possible :saluting_face:

Thank you. If I can do anything else, just ask :slightly_smiling_face:

1 Like


Random non-deletable ghost pages visible in the graph pane but not anywhere else


1.Open the graph view anywhere
2. I looked at orphan pages cluster
3. There are several untitled objects with ‘human’ layout’ that are visible
4. Observe the page. In the object menu, it is not presenting a delete option to remove the said object
5. I was able to provide you a screen capture of the bug, here it is:


These pages should not exist.


  • OS:
  • Device:
    MacBook Pro M1
  • Anytype Version:


It might be related to: Undeletable objects .

1 Like