Unable to create a Set for Tasks

I had a set for my Tasks, but mistakenly changed the objet type that said Set should display and couldn’t come back. Now “Task” is not an option when selecting the object type to display on a set.
Tried re-installing Anytype, and deleting the Roaming\anytype2 folder but I’m getting the same issue. Not sure if I did anything else other than changing the object type on the set, but I’m pretty sure I didn’t.

System Information:

  • OS: Windows 10 21H1
  • Anytype Version:0.23.0

I can’t reproduce the error (?) with other object types.

I just noticed the “Task” type is not showing up on the Library, but it does appear when creating a new object:



Again, I’m not sure where did I mess up haha

OK, I saw what happened. I deleted the object type “Task”. The weird thing is that I did that from inside a Set…
Fixed it just by restoring the object type.
Though, as far as I know, we shouldn’t be able to delete a default type, correct?

It’s worse than I first realized…


I just don’t know what happened, but I can’t restore those. Could restore them on the Android app, but the change is not syncing.
I can’t keep using the app untill I can fix this, as I need a few of those types.
I’ll leave it for the time being, and will keep trying next week, as I’m a bit short on time.
Hope someone can help!

You could try a cold sync in the desktop app if that restores the types for you. Backup your keychain phrase, Delete the working directory ( File → Show Working Directory from the app) and try logging in again

Tried it, but it didn’t work. :confused:
I could finally fix it though, I restored the types from the Android app, but it wasn’t syncing, so when I tried to delete on of the objects from the Desktop’s Bin, seems it forced a sync and everything restored.
This whole thing made me sweat, but luckly was easily fixed.
I’m still not sure if it was a bug or a user mistake, but I’ll leave it up just in case someone else comes across the same issue.
Thanks for the help @lynxlove!

1 Like

@JorgeEstevarena Hi!

  1. You made the set from default task type Task
  2. You deleted source from the set
  3. After 1 and 2, the Task object type doesn’t display in the source list and in the library too.
  4. The Task object type displays only when you’re creating new object
    Do I understand right?

Hi @Kirill_Lem!
Yes that’s it,
Though thankfully I think i found the issue and could fix it.
But what happened doesn’t seem right anyway…

@JorgeEstevarena you are definitely right. We will investigate this case.

1 Like