Types missing from Library

Describe the bug
All Types have been missing from the Library menu. Anytype and DIY Types alike. This just happened on the Desktop App for me.
This meant that all my Sets were empty. The links to objects were still active, but the Objects were of Type “Untitled”.

To Reproduce
Could not reproduce on the mobile app.
EDIT (11.05.2022):
I was able to reproduce the bug today. I deleted a tag in a Set of mine which showed the Objects for Type “Meeting Notes”. After I deleted the tag (click on tag → click meatball menu → delete option) the set reloaded and had no Type set. The Library contains only one Type (Human) and every other Type is an orphan in the Graph view again.

Expected behavior
Types showing up in the Library menu.

System Information:

  • OS: Windows 11 Pro (ver. 21H2)
  • Device Manufacturer/Model: Laptop (Ankermann)
  • Anytype Version: 0.25.4

Additional context
This happened yesterday as I was opening another Meeting Template. I am not sure whether it happend before or after I made the Object.

I was able to get the types back, by going into the “Graph View” and opening all Objects of Type “Type”. They were shown as orphans. After that the Types showed up again in the Library. Now the sets are populated again but some objects still did not turn up in the Sets. After looking at the Graph again they were there but with the name “Untitled”. After opening them it automatically updated the name and everything was functioning again.

1 Like

Hey @DaBootO, could you make a video of your process reproducing the bug?

@DaBootO and also can you please provide Tree diagnostic, it will help us to investigate the problem
Screenshot 2022-07-21 at 12.26.55

Hey @Flip,

I am sorry but the error is currently not reproducible. Maybe it was unknowingly fixed in the last update? (currently on v.0.26.1)

How do I downgrade to an older version and can you give me a hint on how to backup? (Simply File → Export?)

I’d be more than happy to help you out.


Hey @DaBootO,
are your types back again?
If yes I think we do not have to chase this one.

Downgrading is not recommended because of a lot of things changing internally.

But for a general backup I recommend just to backup the data folder of Anytype as there is no bultin option, yet.

@Flip yes they are. They were not “lost”, but simply disconnected as orphans. Simply reopening them from the graph view fixed it for me 2 months ago.

@mordan Do you still need the tree diagnostics? I’ve got a current one and one from 4th May

If I can be of any help hmu here. I mean it seems to be fixed :smiley: If I stumble upon another way to induce this bug I’ll let you know!


As you can’t reproduce it anymore, I will mark it as solved. But please comment here, if it happens to you again.