The number relation doesn't have even spacing

WHAT IS THE BUG

The spacing in between the numbers is not even in the number relation, but when I click to edit them it displays normally. This happens when the relation is on page, but also in the relations overview. (See below)
A gap is added after the first digit if there are 4 digits, and after the second digit if there are 5 and so on. This makes sense for data, but not for years - even if the preset “year” is selected, numbers display this way, putting a gap after the first number.

Screenshot 2022-09-23 at 9.55.55

HOW TO REPRODUCE IT

  1. Add a number relation to a page
  2. Type in number with more than 3 digits

THE EXPECTED BEHAVIOR

Even spacing in between numbers if it’s a year

SOLUTION

Either:

  • have an option to only input the year in the date relation (and not the full date)
  • have a separate year relation type
  • don’t add a gap for longer numbers (will reduce the readability for data)

SYSTEM INFORMATIONS

  • OS:
    macOS Monterey
  • Device:
    MacBook Pro (Retina, 15-inch, Mid 2015)
  • Anytype Version:
    0.28.0
1 Like

I assume thats actually intended to make high numbers more readable instead of using separators.
But in this case, of course it doesn’t make sense.

1 Like

This issue has been added to our issue tracker and was received by the Development Team.

1 Like