The inability to create objects

WHAT IS THE BUG

I can not create objects ; let me explain. When we want to create the object, it can not be done with the object types that doesn’t have a template. For example, in my experience I created 3 templates for the “human” type and I can create objects by either clicking on the “New” button in the sets or by using the "Command + N " shortcut. But in the sets populated with objects that I haven’t created a template for, it can’t be done.

Also, the more worrying aspect is that I can not create objects even from the “/” command for some reason after the 0.29.25 update. The only way that I can still create objects is with the “+” button located in my homepage.

HOW TO REPRODUCE IT

  1. create an object type
  2. do not create a template for it
  3. create a set populated by this type of objects
  4. try to create a new object either by clicking on the “New” button or the Command + N shortcut
  5. as for the “/” command, just try to create a new object from anywhere and see that it does nothing.

THE EXPECTED BEHAVIOR

For the “creating new objects” function to act normal everywhere!

SYSTEM INFORMATION

  • OS:
    Mac OS 13.1 Ventura
  • Device:
    M1 MacBook Air
  • Anytype Version:
    0.29.25

ADDITIONAL CONTEXT

I’ve provided a video-recording for sets bellow for more context:

and for the “/” command:

2 Likes

The Devs are aware of this bug and it’s a top priority.

1 Like

Update 1:

As of 0.30.0 update, I believe this seems to be fixed.

1 Like

@Angelo this one can be closed in Linear if present there.