The app won't open

The app ‘opens’ to a blank screen.

Quitting closes the open window but not the app

Eventually have to force quit the app

Even restarted the Mac, but no change.

Expected behavior

I expect to see the landing page, but only see a blank screen

Desktop (please complete the following information):

  • Device: Mac M1
  • OS Version: 11.5
1 Like

I’m sorry to hear that. Can you please try to launch the app from the console?

Mac, Linux

  • Stop application if it’s running.
  • Can you please start Terminal. In Spotlight you can type “Terminal”
  • Run this command in the command prompt (please correct the location of Anytype app): ANYTYPE_LOG_LEVEL = "* = DEBUG" /Applications/Anytype.app/Contents/MacOS/Anytype
  • Use CTRL(CMD)-A and CTRL(CMD)-C to copy logs from the terminal and send it to the team v@anytype.io

You may experience a crash like this:

It means problem is 100% is in our side and it will be enough to share this crashlog in order us to fix it

If there is no crash, we need to also check if we have some errors in the JS console

  • Please open the app’s path that is shown in Status (press bottom-left question mark → Status)

    For Linux path can be /home/<userName>/.config/anytype2/

    For macOs path can be /Users/<userName>/Library/Application\ Support/anytype2

  • Open devconfig.json and set this data there. If there is no one, you can create new one:

{"allowDebug":true,"debug":{"mw":true,"ho":false}}

  • Start the app

  • Open app system menu.

    Open. Debug menu, from where I could open devtool

    Press cmd + option + I to see the debug menu with developer tools & open console in MacOS

    Press Alt+Ctrl+I / Shift + CTRL + J to see the debug menu with developer tools & open console in Windows/Linux

It means problem is 100% is in our side and it will be enough to share this crashlog with v@anytype.io in order us to fix it

There can be problem with opening particular page. To fix that you need to

  • Open developer tools. Go to Application tab → Local Storage → localhost:8080 → delete the pageId at the right and restart the app

@jmsinnz HI! Did you able to launch Anytytpe?

I have the same problem. This time the Linux desktop app. It opens to a blank screen (with the upper menu bar and a tray icon). Does not go away unless I kill the process. If I run it from the command line, I get this error:

12:24:30.170 › Config: {
“channel”: “latest”
}
Channel: latest
(node:9014) UnhandledPromiseRejectionWarning: Error: An object could not be cloned.
at EventEmitter.t.ipcRendererInternal.send (node:electron/js2c/renderer_init:85:328)
at EventEmitter. (node:electron/js2c/renderer_init:81:357)
(Use anytype2 --trace-warnings ... to show where the warning was created)
(node:9014) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag --unhandled-rejections=strict (see Command-line options | Node.js v17.4.0 Documentation). (rejection id: 1)

Using the flag --trace-warnings does not display anything more. The same holds for ANYTYPE_LOG_LEVEL="* = DEBUG"

UPDATE:

When I tried to look in the console in electron, I found this. It seems like that the only problem is that I have only the 2.27 version of GLIBC and I need 2.29. And since I am not maintaining my workstation, I cannot really do that. That is a shame

Uncaught Error: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29’ not found (required by /tmp/.mount_Anytyp27kT35/resources/app.asar.unpacked/build/Release/addon.node)
at process.func [as dlopen] (node:electron/js2c/asar_bundle:5)
at Object.Module._extensions…node (node:internal/modules/cjs/loader:1199)
at Object.func [as .node] (node:electron/js2c/asar_bundle:5)
at Module.load (node:internal/modules/cjs/loader:988)
at Module._load (node:internal/modules/cjs/loader:829)
at Function.c._load (node:electron/js2c/asar_bundle:5)
at Function.o._load (node:electron/js2c/renderer_init:33)
at Module.require (node:internal/modules/cjs/loader:1012)
at require (node:internal/modules/cjs/helpers:94)
at bindings (/tmp/.mount_Anytyp27kT35/resources/app.asar/node_modules/bindings/bindings.js:112)

My info:

Running Ubuntu Linux, the Ubuntu 18.04 (bionic) release.
GNOME: 3.28.2 (Ubuntu)
Kernel version: 4.15.0-166-generic (#174-Ubuntu SMP Wed Dec 8 19:07:44 UTC 2021)
GCC: 7 (x86_64-linux-gnu)
Xorg: 1.19.6 (14 December 2021 04:11:54PM) (14 December 2021 04:11:54PM)

UPDATE 2:
I installed the correct version of glibc and pointed the executable to the correct libm.so.6. Now it works. Hooray

1 Like

Is this working for you now, too?