Tag colors are reverting back to their original colors

Describe the bug
Changing the color of a tag is reverted back to its own color when I change the color of a different tag assigned to the same relation

To Reproduce
Steps to reproduce the behavior:

  1. Go to a page which has a tag relation
  2. Change the color of one tag
  3. Change the color of another tag to the same relation
  4. You can see the previously changed tag color is reverted to its original color

Expected behavior
A clear and concise description of what you expected to happen.

System Information:

  • OS: Fedora SIlverblue
  • Anytype Version: 0.21.1

Additional context
The tags seems to have a mind of their own :ghost:

It would be great if the color of the tags are also backed up to the cafe node since every time I do a complete sync from the cafe node / with updates, the tag colors seems to be changed from what I change them to. I’d raise a separate request if the team / community feels it should be addressed separately.

Assigning the tag colors from a set seems to make them stick


@lynxlove Hi! Please, update anytype till 22.3 version


Hi I can see this is marked as resolved but I’m having this problem on the latest version, Windows 11.

Very strange, on windows 10 I could not reproduce the bug :upside_down_face:

Happened a few times today when I was changing colors

Did you have more than one Anytype instance open at that time (PC, mobile)?

No I was only using my computer with windows 11

I don’t think it’s the mobile fault since I did not have Anytype installed on mobile when I tried to experiment with this bug yesterday.

I think it had something to do with pages and sets + the relation tab within the page.

Other than the colors reverting back to the original colors, names reverts to their original names too. In other words, renamed tags wont be saved.

To start fresh,

I tried creating a new tag and a new relation, and they don’t have this rename, color, or deletion problems when you change them in sets.

but the problem occurs (even with new tags/relations) when you started to change the relations from the page.

From there on, I wasn’t able to delete/rename my tags. They (tag B) return back to their original names when you change another tag (tag A) color or name. Vice versa.

There’s something buggy the moment you touch the relations within pages.

1 Like

This appears to have been solved in version 0.27.0 (though it isn’t listed in the changelog) — can you please confirm? :smile:

This does not yet seem to be resolved, but the behavior is quite strange: colors do never seem to be saved when you only change the colors without adding the tags, but only sometimes the change is reverted when you do add them.


Strangely, since the release of 0.27.0, I couldn’t replicate this issue with tags, however after closing and opening Anytype today, all of the issues have returned, and some changes that were previously made and successfully saved (without issue for several days), have been reverted :thinking:.

Maybe it is not related to the Anytype versions, but something to do with how the data is synced to and retrieved from the backup node?

1 Like

We are in the middle of reworking relations and options completely from technical point of view - the way they are stored and the way we work with them, so all problems with tags and stuff will be hopefully gone for good after that work is finished.


Awesome! That is great news and probably a huge task!

It started in February, lol =) This is actually a prerequisite to Inline sets, so I will start working on them as soon as this is complete. I think 2-3 months and Inline sets would be available.


This issue has been added to our issue tracker and was received by the Development Team.

This will be fixed in new relation and option storage system.