Syncing errors between different copies of anytype across devices

WHAT IS THE BUG

I have 3 devices, a personal pc, a phone and a work pc. All three are desynched from each other. All indicate with a green synced status that they are up to date on relevant pages.

This morning I installed anytype on my work pc, entered my passphrase and it seemed to download the data to that pc without issue. Then I made some notes regarding work, added a link to the main page for that set of pages to a central “homepage” i maintain and favorited that main page as well.

Back home my copy of anytype did not have those changes. The “Homepage” however indicated a green synced icon. I tried clicking on this to see if i could get more information on what might be going on. None of the information displayed indicated there was any issue. It was convinced it was up to date while I am certain this is incorrect.

Curious I looked at my phone. It seemed to be suffering different problems. My phone and home pc copy of anytype were not in the same state. The central work page cannot be found in favorites. Not just that, another favorite item is also missing, despite not having touched it at all. A link to the main work page does exist on the “Homepage” but it is perpetually displaying a loading icon and the link does not function.

I tried a number of other actions on my pc to see if i could trigger an update on a specific page or anytype in general. I could not. Finally I closed and restarted anytype hoping that would force it to properly sync up. It only partially did so.

My pc updated to a state seemingly identical to that of my phone.

Additionally I established none of the work pages could be found from Search or the Graph.

These pages I created at work were not large and aside from one small image for the page icon consisted of only plain text. Syncing these should not have been a challenge.

Since I started writing this bug report some changes have occurred, possibly trigger by me double checking certain things. My PC’s favorite additional missing page has returned, additionally the work page that should be there is “present” as a blank object with no icon, title or type.

These things have only happened on the “front page” of anytype, they are not represented in the sidebar.

On my phone the missing page has returned, but the central work page is still missing from favorites.

HOW TO REPRODUCE IT

I do not know how to reproduce this problem. As a best effort to help though I will include images showing the problem. Thursday morning I can add images of my work pc’s state, if that would be helpful.

Home PC Front Page state: https://i.imgur.com/UV8wVLN.png
Home PC “Home Page” state: https://i.imgur.com/UV8wVLN.png

Phone Front Page state: https://i.imgur.com/NasVIzL.jpg
Phone “Home Page” state: https://i.imgur.com/WF7XerW.jpg

THE EXPECTED BEHAVIOR

I expect anytype to properly sync data between installations, if it is unable to do so I expect it to indicate this to me.
I expect that if anytype shows a green synced indicator on a page on two different installations that those pages are identical.
I expect that if anytype shows a green synced indicator on a page that there are no issues with the syncing of any kind.
I expect that if I click the sync indicator on a page it will double check to see if it is accurate.

SYSTEM INFORMATION

Home PC

  • OS:
    Windows 11
  • Anytype Version:
    0.31.0

Home PC

  • OS:
    Android 12
  • Device:
    Redmi Note 9S
  • Anytype Version:
    0.14.0-alpha

Work PC

  • OS:
    Windows 10
  • Anytype Version:
    0.31.0
1 Like

Hi @MoonWolf, thanks for the elaborate bug report! Hopefully, these kind of sync issues will be resolved with the new infrastructure the Anytype team is working on. So, as unfortunate as it is, we’ll need to wait for that project to be completed (hopefully within a few months) before these issues will go away. I will mark your issue as “In Progress” as the team is working on a solution of sync issues in general

1 Like

Alright. I look forward to this infrastructure change.

2 Likes

So do I! If you feel lucky or adventurous you can join the Nightly Ops testers group to get early access to test the new infrastructure. Warning: not for the faint hearted :wink:

1 Like