Syncing barely works

I have a Set that shows on Android and doesn’t on my desktop client (Windows).
Do your instructions apply to Sets as well?

In any case, I can’t open the set on desktop (as it does’t show there, neither can be found via Search).

I am experiencing a bunch of errors trying to sync on Android and Windows. After a full system restart I am finally passed the “preparing” message in the windows applications but I am still stuck like this. Just a bunch of swirling icons for a few of my recently created notes.
Anytype_nHiyrWawj0

4 Likes

@pixelsnis @irongiant Hi! Could you please provide object and tree diagnostic. It will help us investigate the issue

Screenshot 2022-09-06 at 17.59.51

Any update on my syncing objects? I provided the logs about a month ago.

What is the status on the sync issues?

As of yesterday I discovered have very inconsistant syncing.

On the same page/object I have a link to a set that doesn’t syncs to my android phone or work laptop (both on my own wifi network) while at the same time changing headers, alignment and text style from blocks syncs in (almost) real time on that same page.

I can only take the info from here. Says everything should work.

@Jeroen

I put an inquiry in with our CTO and this was his response:

1 Like

I just checked, it is now synced on both my phone and work laptop. So as of now, it can take a while for sync to fully work?

Are there different types of syncing or priority for sets/objects/blocks? New sets take longer (say up to 12 hours) while changing text styles is near real time.

Maybe it would be nice to have a more detailed sync menu/screen? Where is says what is syncing or stuck? perhaps even a request sync button to force a sync manually?

Related requests:
https://community.anytype.io/t/live-progress-bar-for-sync-status/1627

1 Like

Those question have to be answered by the team.
@Angelo

I am having the same issues between a MacOS client and a Linux client. As you can see in the screenshot, the Linux client is showing the objects as if they are loading, however, they will never actually load. If I navigate off of the home screen, Anytype shows it is fully synced.

3 Likes

Video of bug - Attached Below

WHAT IS THE BUG

Regularly unable to open sets, most often My Notes.

HOW TO REPRODUCE IT

Create note on one system
Make sure it shows ‘synched’
Open other system, confirm it shows synched, attempt to open note.
Have cleared cache/content, signed out and in, allowed ample time to sync.
All from local LAN

Note will not open.

THE EXPECTED BEHAVIOR

Note should open without issue.

SYSTEM INFORMATIONS

  • OS:
    Windows 11
    Android 12 (removed for testing, issue persists)
  • Device:
    Dell XPS 9560 & AMD Desktop
  • Anytype Version:
    0.29.1

ADDITIONAL CONTEXT

At the :45 second mark, the application UI completely locks up.

1 Like

Hello - I read through the v0.30 release information, and I didn’t see anything specifically referencing this issue.

It also shows this issue as still “In-Progress”. Is there any formal information you can share?

I really want to go back to using AnyType, but can’t risk these sync issues and lost data.

Cheers, -Ian

6 Likes

Hi, I think I have problems with syncing as well. I edited some relationships on desktop (removed and created another one with the same name), but on mobile they appear as deleted. I tried clearing the cache, logout and login again but still nothing.

Both apps show as “Synced”. Am I doing something wrong?
Desktop Version: 0.30.0
iOS Version: 0.20.0 (54)


Plus one for this. I have a solid broadband internet connection, and yet, so much data is missing from anytype. In the version history, at least, the latest version has all of the data… yet the current version does not display it.

Very worried about corrupting all of the notes that I keep in Anytype. Please provide feedback on when you foresee a fix.

1 Like

Also there are pages that were completely full with painstakingly written notes and tutorials. Now only the heading is left, and the version history does not have a record of the complete version. Is there a way to selectively restore pages from version history no matter how old? I.e. before the data seems to have disappeared

1 Like

Very unfortunately my 6 most important objects are broken. I just created them very recently on windows but no matter how many times i log in on Android they dont sync. Syncing needs hours every time i log in which alone is super time consuming but my 6 objects which still dont wanna sync is just sad. I still have a bunch of other object that never sync. I just hope this gets fixed.

1 Like

Hey again. Just in case you didn’t see my reply to your other comment about the same thing :point_down:

Hey everyone,

It became quite calm in here after the beta launch with the Anysync protocol.
So there are probably much less issues now :+1:

If you have sync issues with the beta version please open a new topic as I will close this being the “obsolete alpha sync problem” topic.

This topic was automatically closed after 7 days. New replies are no longer allowed.