Syncing barely works

Describe the bug
Syncing almost never works. Both devices say “Synced” but they show different information. I have to restart the apps on both devices several times before they decide to sync correctly. Sometimes the sync is only partially complete – I’ll add an object on my phone, and it’ll start syncing it to my Mac but stops half-way through typing the title and now I’ve got an incomplete object on one end that never syncs to the other predictably.

To Reproduce
Make any change on any device. Syncing will not keep up with the changes.

Expected behavior
Both devices should show the exact same information quickly and predictably.

System Information:

  • OS: Android 12 (Bliss ROM), macOS Monterey 12.3
  • Device Manufacturer/Model: OnePlus 7T, MacBook Pro M1
  • Anytype Version: 0.24.0 (macOS), v0.6.0-alpha (0.17.27) (Android)

Additional context
N/A

Hey,
are you behind a proxy? Or having some other limitations?
Do you have this problems also in a local network?

Yes, I’m using iCloud Private Relay. This is happening on local network. I don’t think Private Relay should be an issue, one of my own apps works only on local network and it’s not affected by it.

Could you try it without the Private Relay function for some time, to be sure?

That somehow made it worse. Now when it manages to sync, it loads in outdated information that overwrites the changes I’ve made and want to sync.

I experience the same.

Edit: Windows laptop, Android phone

What device combination do you use?

1 Like