Sync to and from Windows 10 is not working or very slow

Hi forum,
I’m new here hope this is the right Place/Category for.
I like Anytype a lot.

Unfortunatelly it has have one big draw-back in my ecosystem.

Situation

I use Android Smartphone,
combined with macbook Pro Notebook,
and an Eve V (kind of cheap surface clone)

The sync between Android and Mac OS is quite smoove and fast.
Sometimes there is a gap between the synced status about 20-60 secs.

Problem

But the sync between Android to Win 10 or ViceVersa AND also the Sync between Mac OS and Win 10 is kathastrophical.

Most of the time there is NO sync at all (although Anytype in Win 10 sync status is green and synced).
Sometimes it happens but after 10 Minutes behind the executed sync-process between Android and Mac OS.

Workaround

My Workaround is to deinstall and reinstall Anytype on Windows. Then all is fine. But this is extremly timeconsuming and error prone.

So I would like to have the ability at least to flush the data on wind 10 Anytype so it will reload the data from Backup or other devices.

Questions

Q1: => Does anyone has a solution for (Flush the Win-Anytype-Data/Cache)?

Q2: => Or is there the possibility to enforce a sync-process from Win-Anytype App?
(I looked on google, here in forum, on notion-docu … no match found)

Q3: => I tried to shut down Anytype on Win10 and restart. But the restart ist too fast I guess, so there have to be some sleep process and maybe hold-up the data in cache, also when I shutdown the Win-App.
Is there a KeyStrokeCombination to shutdown or restart without Cache?

Device-Details (maybe for Bug-report)

Mac OS: Big Sur 11.6.6 (20G624) | Anytype Version: 0.26.1
Smartphone: Android 12 Kernel 4.14.113-23686045 | Anytype Version: 0.7.0-alpha Lib: 0.18.1
Eve V v1: Windows 10 Home Version 2H2 Build 19042.1466 | Anytype Version: 0.26.1

All devices are connected to the same WLAN. Any App are clicked on «search for update» => You are on the latest version

Conclusion

Seams to be something in Windows Anytype Version. Because sometimes Sync is working sometime not at all. The other devices have no problems with. Or in better description it goes tolerably long to sync.

Looking forward to a push in the right direction, maybe a link about more information or help
Best regards
Martin

4 Likes

My Anytype stopped syncing completely (Windows 10).
It was after I deleted a bunch of items in my History.

It is not a solution yet, but a relevant feature request:

1 Like

I’m not too familiar with how the Windows firewall works (I’m primarily a Mac person!), but have you ensured that Anytype and all of its processes are whitelisted on the firewall/the WLAN is designated as a home network? The slow 10-minute sync delay, in my experience, is characteristic of when the two devices cannot establish a direct P2P connection and are instead connecting solely over the cafe node, which can be slow. Perhaps the firewall may have been preventing Anytype on your Windows machine from establishing a direct P2P connection.

Can you check that, try out the setup for a couple days, and see if that fixes the issue?

1 Like

If this is needed, shouldn’t the app do this (or request the user to do this) on installation, since it affects it’s basic functionality?

1 Like

@qualquertipo you are right, on Windows it should not be up to the user to open the correct ports in the firewall for inbound and outbound connections. The home network is of course different, but for people that do not have their own DHCP and DNS servers running (like PiHole, AdGuard Home, and similar) AnyType should just work. It is probably most helpful if anyone with sync issues posts their network config here:

Someone from the Anytype team can then check whatever other troubleshooting steps are needed to get all relevant info to reproduce the issue internally.

@_Martin could you give that a go?

1 Like

Hy @edwards and @sambouwer and all the others thanks a lot for help.

Sorry I have to ask back. I’m absolutlly not the network and firewall guy. :sweat_smile:

@edwards: Can you check that, try out the setup for a couple days, and see if that fixes the issue?
Yes, of corse; but I don’t know where and what I would have to check.
Q1 => Maybe a bit of help or a link to a step-by-step?

@sambouwer: @_Martin could you give that a go?
Sorry I’m not native english, I can’t quite relate to your final question.

What do you mean with «that».
I tried to find «that» in your linked comment «what are your network…»
Or is it referring to @edwards reply about firewall?

Q: If it is about the network, where I find and what kind of Information should I collect and post?

Best regards
Martin

Hi @_Martin, sorry for posting such a vague question :stuck_out_tongue: . I had to re-read my own post three times before I knew what I wanted to ask, so the confusion is understandable. My intention was to ask you to share your network setup in the topic that I linked. Sharing your network setup could be as “simple” as this example that I made up:

“I have an Android phone, an iPad and a Windows laptop all connected to the same Wi-Fi network. On my Windows machine I have no custom firewall settings but I am sometimes connected to a corporate VPN which seems to break syncing my changes to other devices. I have a modem/router from Verizon with its default settings.”

Or in potentially more custom setups: “I have a bunch of devices (Android, iOS, iPadOS, MacOS, Windows, Linux) and they are connected to different Wi-Fi networks (2.4GHz for guests and older devices like the Android phone and iPad, 5GHz for home users). I use PiHole to block outgoing DNS requests for trackers and ads, and I have custom firewall rules to block everything apart from port 443 for HTTPS traffic and port X and Y for use case Z. I have a separate modem setup in passthrough mode and separate router setup in a mesh network with four other access points. When out of the house my devices connect to my personal/selfhosted VPN hosted on a home server/NAS. When in the office or working from home I am connected to a VPN or corporate network with limited connectivity apart from approved resources.”

I hope that clarifies my question :slight_smile:

3 Likes

I’m also having android-windows sync issues, but mine doesn’t get resolved by a reinstall or by firewall settings. Instead, I lose all my objects/relations every time I reinstall, like a reset except I have these “object is still syncing” boxes. So at this point I can’t use Anytype anymore for fear of losing important data.

I agree that if there’s a specific setup that needs to be done, it should be mentioned to the user upon installation. I always try to self troubleshoot, but I’m not that good with tech so there’s only so much that I can do. :sweat_smile:

Thanks @smabouwer, you have cleared the question. And I have «tried» to do what you recommended.

But

At the end I’m quite sure there is not firewall who is blocking on my windows-PC. Also I guess this is not a firewall or network problem (you see in my «assumtion» in my linked entry).

Thanks again

1 Like

Thank you @edwards.
I have tried to figure out (as an Network-NONprofessional) what my network, antivirus and firewall settings are.
I’m quite sure there is not firewall at least no-one who is not «default» in settings. But as I wrote in the comment What are your network configurations? - #18 by _Martin in the section «Wish» it would be great to get some recommendation for Tools to collect this kind of stuff.

Maybe someone here is a windows-specialist who could recommendent some tools, so I could collect the necessary-settins and secure-tools for the tech-guys and girls from anytype so they could do a better debug-job with deeper knowing about customer-system from customer with no tech-background.

Even I’m facing the same issue
Windows 11
Ver - 0.26.1
Android 11
miui 12.5.4
ver - 0.7.0
Sync happening in windows after sometime(suspecting 30min to 1.5hr )

1 Like

Same problem here - Windows version will not sync.

Windows 10
Failure to sync regardless of if it is on the same WIFI as other devices, or a separate network.

Edit to add:
So CLOSING Anytype and opening it again seems to have no effect on sync no matter how long I wait. Anytype SAYS it is synced, but changes made on my Mac are not showing up on Windows.

FORCE QUIT Anytype, and then reopening it seems to have triggered a sync, and now the changes from Mac desktop are starting to appear on my Windows desktop version.

@_Martin I have moved your topic to the Bug Reports category and updated the title. Let me know if you prefer to revert these changes, but I think we have enough evidence (N=4) that sync from and to Win10 is not working as it should.

1 Like

Hey @sambouwer ,
Thank you very much for the supporting move.

For sure, it looks like I (we) can not fix from my (our) side.
So bug-fix would be great.

Thanks!

1 Like