Sync not working even disabling PortMaster and Tracker control

Describe the bug
Android mark page as “Synced” but it’s not
Windows mark page as “Not Syncing” and stuck on preparing for 1h now
I tried to disable both PortMaster on Windows and TC on Android but it still does nothing…

To Reproduce
Steps to reproduce the behavior:

  1. install app on Android
  2. install app on Windows
  3. create a new page on Android, see if after it’s marked as “synced” it’s on the desktop
  4. create a new page on Windows, see if it manage to sync

Expected behavior
Syncing correctly

System Information:

  • OS: Android 11, Windows 11
  • Device Manufacturer/Model: Lg Gram, Oneplus Nord
  • Anytype Version:
    Win: 0.23.5
    Android: 0.5.1

Hey, @mikeler
Sometimes it take time the app to sync. Try restarting it and wait a bit.
If it still has an irrelevant state, please proceed with this guide: Sync problems, White screen or not responding, high resource consumption - #5 by Vova

I tried running it in debug mode and deleting the “data” folder after disabling every possible “blocking program” and

  • now it won’t login saying “can’t run service ‘anytype’: add replicatorAddr attempts exceeded” → the other ticket said it was resolved on the latest update but still…

Tried reinstalling but no luck

I don’t seem to find the cause in this forum :confused:

The app seems to be syncing to the relay node since after I uninstalled and deleted the cache I logged in and the test note I wrote was there

And yes, I tried doing it many times (9.0 KB)

@Vova Any help? I tried it on Debian and it works (the title change doesn’t sync but the body sync seems to work)

It seems to be a Windows problem

yeah i am facing the same issue (390 Bytes)

I have similar problems on Windows and android. Synced, but still missing some object’s/sets.
I logged out, deleted the cache and logged in again with no luck.
I did reinstall Anytype at least 3 times on each device. I let Anytype sync overnight 12+ hours, even 24+.
After reinstall, the overall syncing works fast and some pages that weren’t syncing last time are synced now.
Still some pages reaches the status synced too fast, and objects are not syncing.
The results are the same. Important to mention is that there are 2 kind of sync issues I experience;
There are always the same 10 objects that won’t sync on Android and Windows since months.
And there are now the random objects mentioned in this post that won’t sync after every new installation.

I found out that some sync issues I have are related to linked objects of mother pages that are already synced. As an example, I have a diary template, including 10 objects I often use. After 7 days, this means there are about 70 relations. So it seems there are some complications syncing all the linked objects when objects are linked too often.

Made a hard reset of my windows laptop, I didn’t install Portmaster this time and it syncs good.
I don’t know the cause but I guess the problem is related to custom network interfaces

Describe the bug
I created a new object on Android and 15 minutes later, it still hasn’t synced to the desktop app. Both devices connected to the same wifi and synced status on both is green “synced”.

To Reproduce
Steps to reproduce the behavior:

  1. Go to Android
  2. Create an object
  3. Try to find the object using the desktop app
  4. Doesn’t exist

Expected behavior
Objects created on Android should be immediately synced/visible on desktop app.

System Information:

  • OS: e.g. Windows 11 / Android G950FXXUCDUD1
  • Device Manufacturer/Model: Microsoft Surfacebook / Samsung phone
  • Anytype Version: Desktop: 0.24.0 – Android: 0.17.27

Additional information
The object has now appeared but I’m keeping this bug report because it took 15+ minutes and required me creating a NEW object of the same type on desktop before the Android object appeared in the set.

1 Like

@dddmggg Are you stil having sync issues?

Closing the topic because there is no response. Please open a new topic or flag this one to be reopened if you still experience this issue.

This topic was automatically closed after 12 days. New replies are no longer allowed.