Sync failures between MacOS app and iOS

I looked for a similar problem and the only one I found was the one I posted some months ago which has been closed since then. Sorry for the repetition…

WHAT IS THE BUG

Some objects (pages) created in the Desktop app don’t sync in iOS and in some cases (pages created the same day, at the library making research) the content disappears.

HOW TO REPRODUCE IT

  1. ᅟCreate page
  2. ᅟSync with iOS → bug (grey box on Dashboard)
  3. Open the objects on Desktop app and realise that they are empty (only the title of the page appears → then they appear as non existing on iOS)
  4. Uninstall Anytype on iOS, reinstall it and login again and nothing happening. Actually, my whole pages sets is in Grey on the iOS app and I must look for them as individual objects…ᅟ

THE EXPECTED BEHAVIOR

ᅟThe sync to work for all the objects

SYSTEM INFORMATIONS

  • OS:
    iOS 15.7 / MacOS Monterey (Intel) 12.6
  • Device:
    ᅟiPhone 8 / MacBook Pro 2020
  • Anytype Version:
    ᅟ0.18.0 / 0.29.0

Please open the object on Desktop, that is not synced to iOS. Then go here:
image
and attach this file here.

Not sure how I am supposed to share the file with you…

Should be possible right here:
image

Thanks :slight_smile: I tried this way but .log file cannot be uploaded…

1 Like

@Angelo Can we add .log to the list of allowed files?

1 Like

@Flip Should work now, can you check?

Looking good. @Camille Please try again.

1 Like

at.dbg.bafkud5kufq5v5jdq4r22b4wbb7zyhig6wfhfr2rghiiwg5iaoho3yqly.20221020.183220.15.zip (237.1 KB)

And I am so sorry!!! I made a confusion earlier. It seems that the file I have to share with you is a .zip… :roll_eyes:

Thanks for all the help!!!

Update 21.10: The problem seems to be the kind of object. The set made of “Pages” doesn’t sync. Both in “Sets” and in “Favorites”, the sets made of Pages don’t appear on iOS. The objects I Changed from Page to Documents, appear now in Sets in iOS… Thought it could be useful… Thanks!

Update 27.10: Despite completely deleting and removing Anytype and TestFlight from iOS, the problem is still there after reinstalling the app. I even tried to change the nature of the object (Page → Note) but there is no change (and even the Notes don’t sync completely). This makes me really very sad because I think that I cannot use Anytype anymore in my everyday life. I will have to use another program for my notes. But I will be happy to come back once the bug is fixed (even if it happened before, it was possible to fix it, but this time nothing makes it work…). So sorry…

2 Likes

Hello there again :slight_smile:
I had the hope that maybe the bug would be fixed in v. 0.19.0 but I still have the same problem and some objects (even “note” object) don’t sync anymore between iOS 0.19.0 and Desktop 0.29.1
Am I the only person having this problem?

Thanks again for all your help!!!