Some types still don't show up in filters


Some types like relations, relation options, templates etc. don’t show up when you try to filter them using the object type relation.


I expected all of the types to show up, especially if they are not hidden in the set themselves.


Templates, relations and relation options don’t seem to show up, but types do.

It’s like this in every set.


  • OS:
    Pop!_OS 22.04 LTS
  • Device:
    Dell Inc. G3 3590
  • Anytype Version:
    Version: 0.31.0
1 Like

@isle9 Has this improved in v.0.31.0?

Still broken, same types not showing.

It would be nice if you could provide either screen recording or screen shots, with some indication markings if possible.

Steps of reproduction are also essential because for now it’s not really possible to recreate your circumstances on our end.

Are you having this issue in every set?


Templates, relations and relation options don’t seem to show up, but types do.
It’s in every set, yes.

1 Like

Thanks @isle9, I added your screen-shot to the topic.

This report has been added to our issue tracker and received by the Development Team.

1 Like

What’s unclear from this screen-shot though is, what Type is this a Set of?

I too have observed some problems with filtered views.

But in order to have objects appear here, they should meet both

  • the Type criteria of the Set (for example Book)
  • what’s being queried in the Filter

The latter, in your case, is the name “relation”.

You didn’t actually select the pre-installed Type “Relation” because the R isn’t capitalized. It seems you have entered in your own custom Type called “relation”, and maybe created it inline during the search?

Either way, it won’t appear here if there aren’t any Objects of the particular Type this is a Set of.

These filters are useful with relational sets. The query I’m suing is the object type relation so all object show up in sets including relations, relation options and templates. That’s why I want to filter them out since I usually don’t want these to be shown in my sets.
The capitalization doesn’t matter, I’ve tried both for all 3 types.

edit: I did this screenshot in a hurry, just to show you a quick example.

1 Like

These still don’t seem to show up in the newest beta version. I tried making a set of sets that all have a specific relation in their set of relation, but only types showed up in the filter search menu.