Some objects created on iOS app don't sync with Desktop

The bug
Few objects created on the iOS app don’t sync with my macOS app. Each time both apps displays a perfect sync states (green dots on both). It happen a few times with different Objects.

Update: Desinstalling Anytype and all its components, then reinstalling it has solved the issue a few times.

To Reproduce
Steps to reproduce the behavior:

  1. Create a “page” Object type. (it seems it’s always this default type that causes this issue).
  2. Rarely, but sometimes the synchronization takes several days to be done.

Expected behavior
Synchronization that works.

System Information:

  • OS: e.g. iOS 15.0.1 / MacOS 10.15.7
  • Device Manufacturer/Model: iPhone 8 / MacBook Pro
  • Anytype Version: for iOS 0.6.0 / for MacOS 0.21.9

Additional context


This is an answer to @AyneHancer: Well, it is solved if you delete Anytype desktop and reinstall it again (I guess since it is happening to me right now but had no time to uninstall and reinstall Anytype on my desktop yet). So I am not completely sure that it is solved since the issue is still there. No one else experiencing this problem? Thanks!

1 Like

I will investigate and contact the few members who had and still have this kind of problem. Thanks for your feedback.

I’m having the same problem. I’ll try reinstalling it.

@Camille & @isle9 Next time please try the official procedures to either fix or gather data for the development team about this issue. :wink:

1 Like

Many thanks! :slight_smile:
Camille

Cheers! I’ve bookmarked the whole page for future reference.

Seems to be solved, as Camille mentioned in the original post.

Hmmm… Afraid this is not solved. One of the objects (a page with only bookmarks) completely disappeared from iOS. It’s still on the desktop app (Mac) but no way to have it back on iOS, even after uninstalling the app and reinstalling it as recommended.
Any further advice? What kind of data should I gather?
Many thanks in advance!