Some emoji not displayed inside Relations on Windows


Emoji support isn’t fully realized in-app.


  1. Set up page icon
  2. Use emoji in relations
  3. Insert emoji via Ctrl+E (or other way) in text
  4. Compare results from steps 1, 2, 3


Emoji support work equally in all steps (1-3)


Example with collection icon and relation.


ᅟProvide your setup info:

  • OS:
    Windows 11
  • Anytype Version:

Hi @PavloUA,
thanks for the report.

I’m not sure I get what you mean here, your problem is that the emoji is displayed differently as a set icon and as a page icon? And it’s not displayed at all in the relation?

Hi @kerbless

The problem is that emojis are displayed correctly as an object icon and when inserted into text, but not in relations. The difference lies in the display of emojis in relations; they work well elsewhere.

For example, if I wanna use :us: emoji for object icon or insert this emoji into text - AnyType will display emoji as :us: but in relations AnyType will display “us” instead of :us:
I know that incorrect emoji displaying is an issue of Windows OS, but any other apps fix this trouble on its own side.


Now it’s clear, thanks! I will update this post to make it easier for devs to pick up and try to replicate.

This report has been added to our issue tracker and received by the Development Team.

Thanks, @kerbless. But it’s not some emoji – all emoji inside Relations. Some of them shows as “US” (following the example; not :us:), another one – use system emoji style instead of AnyType style (similar to the Apple)

Just emoji support as in the text & icons will be perfect fix for the Relations! :slight_smile:

SorryI should have said that I changed to “some” because when I tried to reproduce your bug I couldn’t with some emojis.

After your last message I’m not sure we’re on the same page so to sum it up, for you:

  • emojis work well as page titles
  • emojis work well inside text blocks
  • emojis don’t work and are either not displayed or displayed differently inside relations?

please correct where I’m mistaken

  1. Yes
  2. Yes (1 founded bug in fixing)
  3. User can insert emoji into relations. Some of them will not display at all, some of them will display differently – following system emoji list (I think, Microsoft once). All emojis not displayed correctly in Relations – in AnyType (similar to the Apple) style.
    It will be cooler if in all places emojis still the same.

Perhaps, that’s explanation will help u :slightly_smiling_face:

1 Like

Thank you, this way it’s super clear.

1 Like

Probably, this will be fixed in the next stable release. In 0.35.17-beta I can’t reproduce this bug.

As 0.36.0 was released, I can mention that on 0.36.0 Anytype now display low quality emojis instead of smth like “US” (on screenshot)

This bug-fix can be improved to display high quality emojis like in object relations: