[SOLVED] [LittleSnitchToBlame] Consistent hard crash opening Anytype 0.24 on macOS Monterey 12.4 x86

Describe the bug

Since updating to the 12.4 beta OS on my x86_64 imac
Anytype seems to hard panic my box upon opening.

It was working fine BERORE updating to 12.4.

I’ve not found any other app which causes a hard panic, but that doesn’t mean too much :slight_smile:

Anytype CONTINUES TO WORK on my apple silicon MBP running 12.4

To Reproduce
Steps to reproduce the behavior:

  1. open anytype
  2. Login
  3. Machine hangs within seconds afterwards.
  4. machine reboots

Expected behavior
A clear and concise description of what you expected to happen.

I can use anytype? :slight_smile:

System Information:

  • OS: MacOS 12.4 (21F5048e)
uname -a
Darwin Kiera 21.5.0 Darwin Kernel Version 21.5.0: Mon Mar 28 19:53:00 PDT 2022; root:xnu-8020.120.43.111.1~1/RELEASE_X86_64 x86_64
  • Device Manufacturer/Model:

    • intel iMac (Retina 5K, 27-inch, 2017)
      • 4.2 GHz Quad-Core Intel Core i7
      • 64 GB 2400 MHz DDR4
  • Anytype Version: 0.24

Additional context
Add any other context about the problem here.

found some ((potentially)) useful log debris in launchd.log

(gui/501/application.com.anytype.anytype2.9286954834.9286955041 [7451]) <Notice>: Successfully spawned Anytype[7451] because non-ipc demand
(system) <Warning>: denied lookup: name = com.apple.tccd.system, flags = 0x8, requestor = Anytype Helper [7491], error = 159: Sandbox restriction
(gui/501/com.apple.xpc.launchd.unmanaged.Anytype Helper .7491 [7491]) <Notice>: added unmanaged active
(gui/501 [100006]) <Warning>: failed activation: name = _oglprof_attach_<7491>, flags = 0x1, requestor = Anytype Helper [7491], error = 1: Operation not permitted
(gui/501 [100006]) <Notice>: service inactive: com.apple.xpc.launchd.unmanaged.Anytype Helper .7491
(gui/501 [100006]) <Notice>: removing inactive unmanaged service: com.apple.xpc.launchd.unmanaged.Anytype Helper .7491
(system) <Warning>: denied lookup: name = com.apple.analyticsd, flags = 0x8, requestor = Anytype Helper [7491], error = 159: Sandbox restriction

If there’s any additional information you’d like, please let me know. I’m not sure where the ‘signal/noise’ line should be drawn here.

2 Likes

This must be really frustrating. Is it still acting like this?

Well well well… This looks like it may be related:

The symptoms match, and I can see anytype falling into the ‘non-webkit’ network interaction category.

will install this and see if I have the same problem afterwards

1 Like

This was totally the problem.

LittleSnitch caused the panic.

2 Likes

Wolf, hello.

Thank you for your report. The kernel panics unfortunately still happen on some systems with macOS 12.4 beta 1.

Apple is aware of the problem and is already working on a solution…

Blockquote

On Tuesday, April 19, 2022, 4:57:20 AM, Wolf Noble wrote:

when I initially installed the fixed version of little snitch, Anytype > > opened and worked for a bit… but I’m still getting a hard panic > > > regularly.

Alexander

Tech Support

Objective Development Software GmbH

it seems this is still a thing. I removed little snitch to see if this improves for the moment

Removing little snitch seems to have helped. Anytype is still running… hours after boot:

1 Like