Simple table not scaling with app window

WHAT IS THE BUG
The simple table as well as set table views don’t change with the app window as I minimize and maximize my app window.

HOW TO REPRODUCE IT

THE EXPECTED BEHAVIOUR
Describe what you expected to happen.
The tables should change dimension as the size of the app window changes.

SYSTEM INFORMATION
OS:
Windows 11
Device:
Dell laptop

  • Anytype Version:
    0.29.1

ADDITIONAL CONTEXT
Hope everyone is doing ok. Happy holidays. :smiling_face:

Hi @Tamalika,

Could you check whether the table scales if you adjust the layout width?

image

Hello. I am a little bit away from my laptop now. I will oet you know as soon as I an able to access the laptop. Sorry for the delay. :sweat:

1 Like

Hello. Sorry for being late with my reply. I did as you said. But it is still a problem, Here are some pictures and a recording. I think a this will be better than me trying to explain in words. :sweat_smile:



Now, if the table scales down , it doesn’t scale up again.
Thanks for your help. Please tell me if I can do anything else to make things clear.

1 Like

All clear, thank you for the additional info!

1 Like

This report has been added to our issue tracker and received by the Development Team.

1 Like

Thanks. Happy holidays. :blush:

1 Like

Thanks. :blush:

1 Like

@Tamalika I’ve tried to reproduce this issue again on the latest version and this seems to be more of an issue with the layout than the table. could you confirm this issue in its core is the same as this issue?

Hello! Hope you are well.
I have upgraded to version 0.31.0. And I have been able to reproduce the problem doing exactly what is mentioned in the Bug report you have shared. Every time I minimize and maximize the window, I have to open the layout bar and click it to get the table or content to readjust. Though, as mentioned in the shared report, the layout bar value stays unchanged. Here is a video. Hope this helps. Please let me know if there is anything else that I can do.
Also, as is shown in the video, I can find no way to make the layout bar disappear if the value is 100. And sometimes a menu with “center align” and “align left” options pop up at the left corner of the window when I only try to open the layout bar.
Have a good day.

Thanks for sharing!

It looks very similar but I’m not 100% sure it’d exactly the same… Let’s leave it as separate topics for now :slight_smile:

Ok. Thanks :blush:

@here

I played a bit with a table and resizing the window.
For me it seems that it’s working as intendend → the table stays the same size ignoring the window size.

So a request to change this would not be a bug report anymore in my opinion.

1 Like

Yes. Now the issue with tables scaling strangely as the window size is altered is gone. :blush:
But I didn’t check if that is the case with thevwhole page. I will try to do so as soon as I can. I am having electricity problems here. :cry:.
Sorry and thanks.

1 Like

Hi. Electricity is back. And I tried changing all the alignment settings again. No strange behaviour from the app on my side. :tada: .
If, things are also ok on your side, then feel free to change the bug report as needed. :smiling_face: .
Have a nice day.

1 Like

Thanks for checking @Tamalika.
I will close this bug report for now.
If other issues come along, feel free to create a new one or flag this if it’s happening again.