Shortcuts are working incorrectly for titles and descriptions

Describe the bug

Changing the text style, text or block type in titles and descriptions should not be possible, yet:

    1. Markdown commands are active and lead to weird behaviour
    1. The /menu has all the unsupported options (titles, links, lists…)
    1. @mentions is active, but does not create working mentions (loading icon animation, non-clickable, disappear upon re-opening; See video below)

To Reproduce

    1. Go to the beginning of a title or description
    1. Type “#” (or any other markdown command or “/” or “@”) and press space

Expected behavior

    1. Markdown commands should be inactive there
    1. /menu should be disabled or limited to colors (like the action menu/handle menu does)
    1. @mentions should be disabled or create working mentions (like in Notion)

Desktop:

  • OS: Linux (Ubuntu)
  • Version: 0.18.59

Additional context

This is related to https://community.anytype.io/t/-/1585 and https://community.anytype.io/t/-/1417, but this includes @ and markdown shortcuts.

video.mp4

@lorenztiel Hi! Thank you for your report. We deactivated the ability to cause slash menu and mentions in title and description blocks, see in the next release

@Kirill_Lem I am glad to see almost all of the mentioned bugs solved in the new release, however, inline markdown commands are still active inside the title and description fields, e.g. ** or ` or ~~ will still trigger-style changes, which are not saved and then disappear after reopening the object.

Version: 0.18.68

OS: Ubuntu

2021-08-31-18-52-56.mp4

@lorenztiel Thank you for your notice! It has been added to the bug tracker