Sets that contains custom Object types & Relations became "deleted" in both 0.36.0 version pre-release and official release (MacOS) and 0.26.0 (iOS)

It’s quite late at night where I am at & English is not my first language, so I apologize if this is terribly described. I will edit back if it is too confusing to understand in the morning if necessary. Thanks!

Sets that contains custom Object type & Relations became “deleted” 0.36.0 version, but remain normal in the previous version 0.35.x.
For iPhone, the same thing gone in the pre-release version 0.26, yet by downgrade to 0.25 it remained normal.

Outline the steps needed to reproduce the behavior in sequence:

Simply by just updated from 0.35.x to 0.36.0 (the official release today) or the previous pre-release of 0.36.0 on MacOS.
The identical bug happened on the iOS 17 from 0.25.1 to 0.26.

Describe what you expected to happen:

Yesterday, I updated to 0.36.0 (pre-release version) and experience the same issue. Both on iOS & MacOS. However, it got resolved simply by downgrade to the last 0.35.x version (a.k.a all object types return). The same thing applied for the iOS version too.

Today, the 0.36.0 (the official release version), the issue came back.

The difference between the bug of pre-release version and the release version is that:

  • the pre-release version has a red “delete” in the object type (I wasn’t able to capture it yesterday).
  • the release version simply has the normal “query” in the object/ relation type. (See attached screenshot)

Sets with default object types remain normal. However, views contain custom relation still also being affected (See attached screenshot).

As of right now, I downgrade to the last version on iOS and still let it run the last version (0.25.1). And every sets and relations remain as expected in my phone. You can see here that sets contain custom Object types remain normal in the iOS app running 0.25.1 version. (This is taken at the same time as the 0.36 version for mac).

I kept a copy of the json export exactly prior to update to 0.36.0, so hopefully worst case scenario I would imported it again. I’m hesitant whether to downgrade back to 0.35 or to import back the json export of 0.35 to this version. Please share your insight, thanks.

ᅟProvide your setup info:

  • Device:
    Macbook Pro 2019

  • OS:
    Sonoma 14.0 (23A344)

  • Anytype Version:
    Version: 0.36.0

  • Technical Information:
    Device: John-MacBook-Pro.local
    OS version: darwin x64 14.0.0
    App version: 0.36.0
    Build number: build on 2023-11-20 20:38:18 +0000 UTC from at #df0868e687be6aa9ffd9d3f5bf4c550ab6e43d5a(v0.29.16)
    Library version: v0.29.16
    Account ID: AB74kHyL5qWfd2HeeXfUuQipJBadsgJy9ZZp6VcUTTfroWUA
    Analytics ID: 0e103b6a-1e2f-49e7-90a7-c674e461a9e8
    Device ID: A6o9zsXGfwRum7KDtMH7XmHdNg62vRMHigRHnYbch7We7B14

This report has been added to our issue tracker and received by the Development Team.

Thanks Angelo!

Just an update hopefully if it can help anyone who might experience this bug & whether it could be helpful to the dev teams

How I recover my lost relation & object types:
(Option 1)

  • I import back the JSON backup (Any-Block export) from 0.35.4 version back to my workspace, and it seems to recovered all relations & object types. I haven’t checked if it recovered 100%, but so far most of my important & heavily organized object & types seem to be reverted normal so far, so I hope it is working as normal.
  • Although there is some sets & object seem to be duplicated. It would be quite a bit of work to clean up but I guess it’s still preferable than losing everything.

(Option 2)

  • I just create a new account & then import the same identical JSON backup from 0.35.4 (a.k.a doing the same thing like option 1 but starting fresh) also recover all relation , object types & everything else perfectly.
  • But as a plus, this method doesn’t have the duplicated problem like option 1 somehow.
  • So I guess if you have less than <1 GB of file just do this option.

Honestly I tried both option and it took like 10 minutes max to recover everything and I have like 6000+ objects so I hope you recover everything like I did!

What didn’t work:

  • Reverted back to 0.35.4 stable version from 0.36.0 official release didn’t restored my relation & object types like the time I did when reverted back to 0.35.4 from 0,36,0 (pre-release version).
  • Yet strangely it still remained normal in my iOS app in both cases?

*What seems to be the problem:

  • When I tried to export the entire workspace from version 0.36.0 (the one where I lost all object types and relation) in JSON backup & compared to the 0.35.4 version. It seems that it contain identical amount of .json files, except for the json files with “ot-” prefix and “rel-” prefix were missing. Which I presume stands for “object type” and “relation” which result in the problem I’m facing?
  • I don’t know if that information could help you guys or not but I just put it there just in case.