Set loading continuously after reinstalling Anytype

Describe the bug
One of my sets keeps loading after reinstalling Anytype. Although, I can access the objects inside that set but the set itself keeps loading on ‘Favorites’ and neither shows on the left sidebar after opening a set or object.

To Reproduce
Steps to reproduce the behavior:

  1. Uninstalled Anytype
  2. Reinstalled Anytype
  3. Logged in with recovery phase
  4. All of the sets were synced perfectly except one.

Expected behavior
The set should have been loaded without taking so much time.

System Information:

  • OS: Windows 10
  • Device Manufacturer/Model: e.g. HP Envy
  • Anytype Version: Desktop 0.27.0

Additional context
Add any other context about the problem here.

Waiting for OP response.

Does the Set ever completely load, or does it load forever? I think the Diagnostics tree might be helpful here, but hopefully @Razor can confirm that.

@Razor can you please help me with this issue?

It keeps loading forever.

Capture

1 Like

I think it’s not loading and is in error state.

I actually have a similar Object:

Is there anything we can do to help? Like logs?

1 Like

I think @requilence can help

@requilence can you please help with this issue?

Is that set an automatically-generated “Notes” set from another device? My Desktop app had trouble syncing that set.

How can you be sure that this Tiles represents your Set since no title is displayed?

If it helps, personally I have several Object Types that are similar, but mine was deleted "Page"Object Types that are now forever loading and undeletable.

Forever loading AND undeletable '''Page'' Object Types

No, that set was created on my Desktop app and now it is not syncing. Although, I can access the objects (Pages).

In my case, I had only my sets marked as favorites.

Ok, thanks for the additional details. One more thing though:

image

It is not showing up there either.

1 Like

Any other solutions, please?

Were you using the Alpha version of Anytype as a final version that you seem to be eager to get your data back? :thinking:

Imagine if everyone would call the Anytype teams members at the slightest bug, they would be overwhelmed! Please note that all bugs are meant to be fixed, but patience is required.

2 Likes

Here’s what worked for me to solve this issue.

On my desktop app, I created a set having the exact same attributes I had earlier. That solved the below error:

Capture

1

However, the set didn’t had the ‘relations’, ‘filters’, ‘sorts’ or ‘views’ I had earlier, nor it was syncing. To fix that, I deleted the set from both, my phone & desktop app, and created a new set and gave the ‘relations’, ‘filters’, ‘sorts’ or ‘views’ which eventually synced with my phone.

Hope this helps in solving the bug!

3 Likes

This issue has been added to our issue tracker and was received by the Development Team.

1 Like

@milindpadia Do you still face the same issue using the latest version?

No.

1 Like