Selecting text on android doesn't work properly

Describe the bug
After editing a few blocks, selecting a text does stop working. This issue happens every time on android v0.5.1-alpha (0.17.23). Reopening the page does solve the problem temporarily.

To Reproduce

  1. Start editing a text block by block. The text should contain a minimum of 10 blocks.

Expected behavior
I can edit as many blocks as I wish without losing the function of editing the text.

System Information:

  • Android 11
  • Samsung S9+ & Motorola Edge 20
  • Anytype Version: v0.5.1-alpha (0.17.23)

Hi @XxxBalCion, I tried to reproduce this on Anytype for Android 0.8.2, but I could not. Could you update to the latest version and see whether it is indeed resolved for you?

@sambouwer The method I showed it in the video is indeed resolved. The problem still occurs though if you first hold a block until it gets selected. I can’t select text after I selected some blocks separately via holding. The object must be reopened to be able to select text again.

It is not possible to upload videos in the forum anymore since a long time. It always says the file is larger than 1GB what isnt true…

hmm, strange! I think I read that in another post on the forum, too, but I never experienced that issue myself. Could you send a screencap to me via Discord or Telegram?

1 Like

Sure its on its way getting those 20 characters for this message:D

Edit by @sambouwer:

I tried to reproduce, but in 0.8.2 the text selection seems quite solid on my Fairphone 4 (decent but not high end hardware).

I first selected a whole block (multiple actually) and then unselected the blocks and tried to select text in two ways: holding and double tapping.

You need to hold a block until it gets selected and then tap to mark the text. After repeating this a few times, you won’t be able to select the text anymore.

Hi @XxxBalCion, that’s where it already “breaks down” for me: when I hold a block, it is not selected but only “grabbed” so I can move the block around on the page… When I release the grabbed block, it is “ungrabbed” but not selected.

Update: If I hold a “code block” it IS selected after I release the block again! It seems like you are using “regular” text blocks, though…

Still cant upload files. Always error files to big.
I made another video here.
https://drive.google.com/file/d/10am-M9KnWKKLd6c4oJlGau0T1MeJQysr/view?usp=drivesdk

The pattern is:
Hold - Tap - Select
Hold - Tap - Select

After repeating this step a few times like you can see on both videos selecting text becomes unavailable and stops working
: (

@sambouwer

Thanks for bearing with me! I was finally able to reproduce the issue! It took me meny tries but at some point the selection was no longer possible. I was able to place the cursor at the end of the block and hold to get the “select all” option. Using the handles to change the selection did not work and the text got unselected.

1 Like

Great to hear : )

2 Likes

Is this still reproducible?

Closing the topic because there is no response. Please open a new topic or flag this one to be reopened if you still experience this issue.

1 Like

This topic was automatically closed after 9 days. New replies are no longer allowed.