Reproducing Loading Pages [Bug]

Okay here’s how I reproduce the loading page bug!

    1. Turn off Wifi/Internet on your Android and Desktop.
    1. Start Anytype on Both the device and create new page with SAME Title, Icon, Description…and on Desktop mark the page as favorite.
    1. Now you have same page(not actually) on Android and Desktop but they are not Synced.
    1. Now turn on Wifi/Internet on Both the device…and wait for few seconds.
    1. Then on Desktop Go to the page and Archive it then Delete it.
    1. Then do the same for Android…Archive the page
    1. Then try to drag and move pages here and there on Android and Desktop. (Make sure Internet was on while this process)
    1. That’s it

here’s the video of it
anytype-loading-bug.mp4

I tired this couple of time and it worked and gave me loading pages. Though those loading pages disappeared after few min. if I Archive them only or if I create a page with internet connected. Deleting is not implemented on Android thats what it make’s them stay on Android unfortunately

So after that I came to conclusion that it was happening because of backup node wasn't able to sync it before archiving it on Desktop and Android, which resulted in loading pages.

I’m not sure if this is the correct way to represent this issue…so im sorry if its not!! :slight_smile:

1 Like

I had a similar issue. One page kept ridiculously long loading (I mean I had to wait minutes every time I wanted to access the page :frowning: even though there wasn’t much content). When I accessed the page I also had to wait half a minute to make changes like posting a bookmark. The page was stuck on android 0.5.0 and windows 0.22.3. Only moving all the content to a new page solved the problem. I don’t know how to reproduce this issue.
A similar issue appear with one of my Sets. On android 0.5.0 version it didn’t synced at all. I had to delete it and created a new set.

Hey @Sedulous, is this still the case in v0.24.0?

Hey @Flip Sorry for the late response.
But the issue is fixed now, and you can close this.

Piggybacking off this post - please let me know if I should create a new one instead.

I still have this problem on iOS (0.13.0) & Windows (0.25.4):

image

Can’t delete the page that seems to be loading indefinitely.

Hey @herb,
yes, please create a new one. But you can link to this one as a related problem.