Relation blocks from template are discarded

Describe the bug
I created a type with some relations and created a template with relation blocks. When I create an object of this type, some relation blocks turn into “New relation” blocks, discarding their types.

To Reproduce
I guess it’s not so easily reproduced. Other types worked well.
Steps to reproduce the behavior:

  1. Create a type with a relation to other custom type object and a URL.
  2. Create a template for it with relation blocks for all those relations.
  3. Go to some random page and create new object of the type.
  4. See some blocks turn from their initial values to “New relation”.

System Information:

  • OS: Windows 10 20H2
  • Anytype Version: 0.23.0

Also when I create an object from another object’s relation block clicking “Add Object → Create object named X”, the template isn’t applied. Is it a bug or should I make a feature request?

@Freewalkr HI! Does it happen only when you create your custom object inside another object, or object discards relation names in independence of creation place?

Tried creating the object from the home page – same problem.

@Freewalkr it has been added to the bug tracker, thank you for the report

1 Like

Hey @Freewalkr
it seems to work fine in my tests in 0.25.0
Can you check if the bug is fixed in this version?