Problem log in to Desktop app

Describe the bug

I first successfully signed up in the Android app using the invite code. Then I tried logging into the desktop app with the keyphrase copied from the Android app, but it takes forever to load, and I have never been able to log into the desktop app until now. I have no problem logging out and logging in to the Android app with the keyphrase.

To Reproduce

Steps to reproduce the behavior:

    1. Go to ‘Anytype Desktop’
    1. Click on ‘Login’
    1. Copy and paste in my keychain phrase and press ‘Login’
    1. It takes forever to load, and I have never been able to log in successfully

Expected behavior

To login into the desktop app successfully

Desktop (please complete the following information):

  • OS: Windows 10 Home, 21H1, 19043.1110
  • Device: Dell Laptop, Intel(R) Core™ i7-6700HQ CPU @ 2.60GHz, 8GB RAM
  • Version: 0.18.57

Additional context

I have tried several times:

    1. uninstall and reinstall the desktop software
    1. log out of the Android app and log in to desktop app
    1. uninstall the Android app and log in to the desktop app

but none of these works.

Hello, same issue here but with first login on the desktop mac version and second login on the desktop mac version on another Macbook.

1 Like

Hey, @Yoda6, @sherlkay!

We are sorry that you have experienced such issues.

It might happen due to several problems and we need to understand what to fix, so please

Sync diagnostics

    • Do you have any apps restricting network? Firewall, Traffic-blockers, Proxies? Sometimes apps like Kaspersky are installed on a corporate device and can restrict the network
    • First, you need to press a special button «Object diagnostics» under Anytype system menu for debug.

    • Get the AnytypeID


You need to start the app from console

App diagnostics

Mac, Linux

    1. Stop application if it’s running.
    1. Can you please start Terminal. In Spotlight you can type “Terminal”
    1. Ran the application through the terminal with this command (please correct the location of Anytype app if needed): ANYTYPE_LOG_LEVEL="*=DEBUG" ANYPROF=:6060 /Applications/Anytype.app/Contents/MacOS/Anytype
    1. Open [http://127.0.0.1:6060/debug/pprof/goroutine?debug=1](http://127.0.0.1:6060/debug/pprof/goroutine?debug=1)
    1. Use CTRL(CMD)-A and CTRL(CMD)-C to copy data from the browser and send it to the team or just send the automatically generated file v@anytype.io.

Windows

    1. Stop application if it’s running.
    1. Can you please start Terminal. In Search you can type “Terminal”
    1. Ran the application through the terminal with this command (please correct the location of Anytype app if needed): set "ANYTYPE_LOG_LEVEL=*=DEBUG" && set "ANYPROF=:6060" && start C:\Users\Administrator\AppData\Local\Programs\anytype2\Anytype.exe
    1. Open [http://127.0.0.1:6060/debug/pprof/goroutine?debug=1](http://127.0.0.1:6060/debug/pprof/goroutine?debug=1)
    1. Use CTRL(CMD)-A and CTRL(CMD)-C to copy data from the browser and send it to the team v@anytype.io or just send the automatically generated file.

Restart the app with repo removal

Your data is safe and stored locally, but sometimes a floating bug prevents app from starting or managing the data.

So you need can try copying your /anytype2/data folder in another place, delete the original one and sync all your data from the server and another devices. Just sign in into application with your mnemonic code and wait until app will sync.

Hi @Vova,

Read your comment about Firewall may restricting network, I click around my Kaspersky Internet Security, set Anytype to trusted application, and now it works! :grinning_face_with_smiling_eyes:

1 Like

Hi @Vova,

I’ve send the requested information, except the Anytype ID that I can’t retrieve because I’m not logged in.

My account has been created on a corporate device, behind a corporate proxy and firewall that I can’t bypass. It’s maybe related to that.

I don’t have a lot of data in my account so if it’s simple I can set up a new account on my personal macbook (with no proxy/firewall)

1 Like

@sherlkay glad to hear that! :smiley:

@Yoda6 If you have the ability to contact your admins, they can unblock the app in theory.

I can try to help with setting up the configuration.

@Vova Sadly I can’t do that, the company is too big with a strict network policy and Anytype is not (yet !) a validated software

@Yoda6 sad to hear. Anyway, you can check if some ports from 49152 to 65535 are open and try restarting the app several times. A free port is issued by the system, it is random but remembered and the next time we try to use it