Png Icon refuses to be applied

Ive been assigning some icons, both jpg and png been working fine.

But, for some strange reason, one .png file refused to be applied as an icon.

Ironically, it was the first search result for ‘anytype logo’, found on this url:

https://avatars.githubusercontent.com/u/50837219?s=200&v=4

im attaching the file specifically bellow:

Ive saved it to desktop, its working on all my image apps, windows show the thumbnail just fine…

I tried placing a different png, and it worked (a bigger one even).

Ive found the same image as a jpg (from linkedin), also 200x200, and it worked.

The file was initially called anytype .git .png- so i tried renaming it, see if it were the space or dots in the filename… nada.

Theories:

  • The file is 24 bits, wich i found out is an export option from some adobe apps as ‘png-24’, claimed to be optimized for web.
  • the picture is from anytypes github, maybe it have the same hash of a picture used in the app itself… idk, wild guess

I couldnt replicate it with any other file yet, the only steps to reproduce is trying to assign this picture as an icon- and it only fails as icon. Ive droped the image on the page itself and it worked fine

3 Likes

The image is now working after the update, Just tried it with the image you had provided.

Still not working for me on:

  • OS: macOS 10.14.6
  • Version: 0.18.15

Same image converted to jpg works.

@vincer @gis Thank you for your notice! It has been added to the bug tracker

@vincer Thank you for your notice! It has been added to the bug tracker

@vincer I could use the PNG from the link you’ve shared as my page icon in v.0.25.0 of the desktop app. Do you still face this issue or shall we consider this to be solved?