PDF shown as `Non-existent object.pdf"

Describe the bug
While on other platforms I have no probelm visualizing pdfs, on Arch linux some of them are shown as Non-existent object.pdf, and some as Non-existent object.

2022-03-29_19-29

If I try to open a Non-existent object.pdf I get sent to a page that says This object doesn't exist, while with Non-existent object I can normally visualize the document

To Reproduce
Steps to reproduce the behavior:

  1. Create a Set of items with a pdf
  2. Upload a pdf from any other device
  3. Try to open it from a Linux machine

Expected behavior
Should be able to see every pdf normally

System Information:

  • Arch Linux
  • Anytype version 0.24.0

Hi @davidegreco! I’m trying to reproduce this on Windows, but I have a bit of a hard type understanding what steps are exactly needed. Could you elaborate a bit on the steps? Hopefully these questions clarify what information I would need to try to reproduce this on Windows:

  • What object type is your Set using? Or do you experience this issue across Set’s with different types?
  • Are you adding the PDF’s directly into the Set or do you upload them to an object within the Set?
  • How are you adding the PDF to the Set/object? Are you using drag-and-drop, or
    image
    or
    image
    or some other method?
    Thanks!

This never happened to me on Windows, so I think it’s Linux related.

I created a template for my university lectures, and a relation called “PDF”

I added them from the set, but as stated before it’s a relation in the template I created

I upload them from my windows device by tapping on the “Upload” button

Thanks for your additional information! That clarifies your steps. Good to hear that you do not experience this on Windows itself, but only when adding PDF’s from a different machine/OS. One other thing that came to mind: is this issue limited to PDF’s and to your custom Set, or can you reproduce this with different file types and other Sets with for example the default “Attachment” relation?

Unfortunately I can’t test those things until this evening, but as soon as possibile I will verify if the issue persists with the default “attachment” relation. Haven’t tried attaching pdfs to other sets

I can guarantee the issue persists with default “Attachments” field and as a simple file (/file). On a default page instead, I have no issue whatsoever

EDIT: as an additional try, I created a new type with only the “Attachments” relation, and I can confirm that the issue persists, so it seems like it has to do with custom types

1 Like

@davidegreco Do you still have this problem?

It seems like it’s solved now, thanks

1 Like