Pasting text with special characters such as / fails

WHAT IS THE BUG

After pasting the text, parts of it are missing.

HOW TO REPRODUCE IT

  1. Copy the following text:
Your task is to generate a short summary of a product \
review from an ecommerce site to give feedback to the \
pricing deparmtment, responsible for determining the \
price of the product.  

Summarize the review below, delimited by triple 
backticks, in at most 30 words, and focusing on any aspects \
that are relevant to the price and perceived value. 
  1. Paste into a page
  2. Some of the text is missing after paste. Text before the first \ of each paragraph is missing.

THE EXPECTED BEHAVIOR

Full text is pasted.

SYSTEM INFORMATION

  • OS:
    Windows 11
  • Anytype Version:
    v.0.33.3

Hey @chillo
Welcome to the forum and thank you for the report.
Copying your text into a page in the pre-release version 0.33.11 looks good.

It was either fixed already or there was another issue.

I see the same bug. As you see in this screen recording, pasting the text into VS Code is correct.

Anytype 0.33.11-beta
macOS Sonoma public beta 2

1 Like

@Flip, looks like you pasted the text in code snippet. However, problem is pasting it to a page.
Thanks @langtind for posting the video, this is the behavior I’m seeing as well.
I can reproduce the bug even in prelease (Anytype 0.33.11-beta, Windows).

That’s right, I copied as it was and it is inside this topic as a code block, thats why.

I can confirm the issue in a normal block.

This report has been added to our issue tracker and received by the Development Team.