Pasting text from Roam Research fails

A piece of text copied from Roam Research fails completely to paste into Anytype. It will simply not do anything (except all blocks “flash” very briefly) if pasted in an existing block, or if pasted in a new block it will delete that block!

This is reproducible seemingly with any arbitrary text copied from Roam. E.g.

  • [[Email]], [[RSS]]
  • Another rabbit hole of [[note taking software]]
  • [[Breakfast]] at 8:30

But keep in mind that the above will not work to reproduce the problem. Unfortunately you must do so with Roam.

I am not sure why this happens, there must be some special character that is invisible, although pasting it into a text editor does not seem to reveal it. The reason I say this is if I then copy the text after pasting it into some other editor (as I did below), it works. Very strange indeed.

Version: 0.16.1

OS: Windows 10

1 Like

A bit old, but Is this still the case for you? I’m noticing that it happens when pasting from Notion as well. Also I was trying to paste from a .eml file (don’t ask) and the same thing. I’ll hit ctrl+c and nothing happens. Not a problem with the clipboard because I can paste the same text somewhere else.

1 Like

Good question! I stopped using Roam and moved to Obsidian as my primary tool, and paste works from that. But yes, I can still reproduce this by attempting to paste from Roam today. If I just paste into a plain text editor first (Notepad++) it works though. I don’t have any problem pasting contents from Notion, although I only tried some plain text with bullets and a header. Would be interesting to know if you have trouble pasting any contents from Notion, and if so, whether you are using Web version or Desktop (I just use Web, which might explain any difference).

Thanks for your reply. I’m using desktop in both cases (for Notion and anytype). It seems to happen quite randomly, not sure what triggers it.

1 Like

If you can, when you run across it again try opening the same Notion page on the Web version and see if it also causes it (copying the same bit of text).

This report sounds related to what I’ve recently experienced as well. Pasting bulleted content from any Gitbooks page is not working. Pasting them does nothing but I can paste them in other text editors. I’ve tried the anytype docs page as well and I can reproduce it fairly easily. I’ll edit this post with images / video later

Edit: Added Video recording of the issue with Gitbooks


Considering the amount of issues related to copy-and-paste in the forum, perhaps a new Tag specifically for copy-and-paste issues should be created?


I think this is worth considering, so I’ve raised the question inside the team. We’ll see what makes most sense for them.

Update: it’s agreed that we’ll add this tag. Now see if you can find some other topics that need it! :grin:

1 Like

Sorry, did not see these requests for some reason. I can confirm that it still does not work well. Here are details:

  • If you copy only a portion of a single line (a bullet point), you can paste to Anytype successfully
  • As soon as you copy an entire line/bullet, or multiple, then paste breaks completely
  • The result of paste depends on whether you are creating a new block or pasting into an existing block
    • When pasting into an existing block of text, no text shows, and the cursor returns to the beginning of the text of that block
    • When pasting to create a new block, on an empty/new line, it removes that line and no new block is created
  • Using Shift+Ctrl-V (Windows) to “paste unformatted” does work, but the bullet points do not get translated, you end up with just:
    - some text
    - some more text
    i.e. the bullets show up as dashes.

Quite honestly the fact that it does not paste, but still does some sort of invisible action (moves cursor, deletes empty block) is kind of concerning with a simple paste action. That really should not happen. Makes me wonder if some kind of “code injection” vulnerability might even exist! :grimacing: