Pasting Markdown links isn't working

Is your feature request related to a problem? Please describe.

As of today, pasting Markdown into Anytype does not re-evaluate it, ending up with incorrect formatting as it just does not interpret it. This is particularly true with everything from links [xxx](yyy) to headers # / ## /... through lists *.

Describe the solution you’d like

It would be great if one could paste Markdown into Anytype successfully. The other way around would be great to: coying from anytype into markdown format.

Describe alternatives you’ve considered

I reformat by hand, it’s painful :slight_smile:

Additional context

None

4 Likes

Markdown interop does work, but it may not support your particular “flavor” of markdown. For example copy/paste between Obsidian and Anytype works well, but not between Roam and Anytype. It seems like markdown paste is a bit limited right now, and should definitely be improved.

Edit: I realized this was marked as Linux, so it might be a Linux-specific thing, I’m not sure. I’m on Windows.

Maybe this is linux specific I don’t know I don’t have a Windows machine to check.

Anyway, for instance creating links with the [google](https://google.com) syntax does not work either

@Erwyn I copied your example and pasted it into my Windows install and it worked as expected. Might be a Linux bug or missing feature in that distribution.

Pasting this into Anytype on Linux results in something between external link and inline code.

On Linux this now results in just the plain text being pasted.
image

Edit: I edited the post title and category. Hope it fits.

Just pasted copied text from here and it worked. Could you be more specific?

I seemed to have made something wrong or with my copy and paste. Works now. Thank You

Regarding one of the post above.
Pasting “google” does make it a link. Only when I go to the end of the link and press space.

Is it possible to instantly convert them from markdown when pasted?

Yes, we have this task already, no ETA though

Okay. Thanks.
I think we can mark this one as solved then?