Pasting markdown from Athens doesn't respect formatting (e.g. bullet list)

Describe the bug

“-” does not make bullet point when data is copied from Athens research

To Reproduce

Steps to reproduce the behavior:

    1. Copy text with main point and sub point indented in Athens research and paste to anytype
    1. See error. - doesn’t make bullet point

Expected behavior

  • makes bullet point

System Information:

  • OS: e.g. popos latest
  • Device Manufacturer/Model: custom pc
  • Anytype Version: e.g. 0.18.68

Additional context

Whenever text is pasted from outside you have to navigate to that place using arrow keys to let it take effect. Such as **text… **

Becomes bullet after the keyboard is moved to that block. It should automatically become bullet point.(this could be another bug report I guess)

Your title here was misleading and unhelpful, something like “- dash does not produce bullet list”. - (dash) does produce bullet points when typed directly into Anytype, which directly contradicts that (former) title. In the topic contents of course you describe what the real problem is, but the title is not useful for finding and differentiating the real issue here.

This is a copy/paste issue. I have renamed your topic for these reasons.

It also appears that this might be a general markdown paste issue. In another thread I reported paste of markdown from Obsidian working fine, but now it doesn’t seem to. So this might be a regression.

1 Like

@Oshyan I did not consider this as a copy/ paste issue. After copying and pasting to anytype there is a space before the - and that’s prevented the bullet list. After it deleting those soace it works. My problem was I did not check the space before the - and hastily reported…

@Srinath so can this issue be marked as solved

@div3xi it’s as oshyan mentioned a copy paste issue. he said it related to other report he made, so you could merge this with that.

Let’s leave this one open for now. It is still an issue and the current title describes it clearly. The other thread is closed/solved I think. This one can be used for general copy/paste markdown handling, perhaps.