Pasting a link (no bookmark) shouldnt link the whole block

Is your feature request related to a problem? Please describe.
When I paste a link into a new block, it seems that the whole becomes a link. I think that neither looks good, nor is the expected behaviour.

Describe the solution you’d like
Only the pasted link should actually link to the website. Not the entire block

Describe alternatives you’ve considered
Manually “unlink” the text I am writing after the link.

Have you tried selecting “dismiss” when pasting a link into a new block? Does doing so give you the result you were expecting?

Yeah, my “problem” is the mentioned behavior while using the “dismiss” option.


Attached screenshot does not result in the whole block linking to the pasted link.

Seems to be only a problem when pasting the link at the beginning of the block.

Played around with this a bit, reported as a bug here:
Typed text after pasted link (non-bookmark) becomes part of link

Okay. Wasnt fully sure, if this is intended behaviour or a bug. Therefore didnt created the bug report right away.

Seems to be solved. :+1:
Thanks at the team