Pages going missing after Archiving and Sync between Desktop and Android

Describe the bug

A page goes missing after restoring it from Archive and not showing on the Dashboard on Android and/or Desktop.

To Reproduce

I was able to reproduce it multiple times, but I’m not sure it holds up every time.

Steps to reproduce the behavior:

    1. Create a new page on one device
    1. Add some text (optional, I think)
    1. Make sure the page shows up on the Dashboard on Android and Desktop
    1. Archive the page on Desktop (pages still shows on Dashboard on Android)
    1. Restart Android App
    1. Page is now shown in Archive on Android
    1. Restore page on Desktop (page is no longer shown in Archive on Android, but also not restored to Dashboard on Android)
    1. Close Desktop App
    1. Restart Desktop App
    1. Page is now “missing” -> Not showing on Dashboard on Desktop, still not showing on Dashboard on Android, neither in Archive nor Search.

Expected behavior

Dashboard should Sync without problems between both plattforms.

Archiving / Unarchiving should behave consistently and restore page to Dashboard on all devices.

Page should not disappear.

Android (please complete the following information):

  • OS: Android 11

  • Device: Samsung S10

  • Version: 0.1.9

Desktop(please complete the following information):

  • OS: Windows 10
  • Device: Lenovo Yoga C940-15IRH
  • Version: 0.18.1

Additional context

Object Diagnostics File is attached.
sync-2021-06-01t15-06-51.zip

The “missing” pages seem to reappear if a new instance is set up and the initial sync (not sure if from a device or the backup node) is done.

1 Like

We are working on this issue and going to fix that in the nearest hotfix release within 2-3 days

Good to hear, looking forward to it. I wasn’t sure if this was related to the Backup Node issues.

It took more days then expected, but it is coming!

New ETA is the first half of next week

2 Likes

:heart:

I think the issue is still there in some way.

    1. Restored a page from Archive on Android (still showed in Archive on Desktop)
    1. Closed Android / Reopened Android - Page disappeared from Dashboard on Android, but still shows in Archive on Desktop
    1. Closed Desktop / Reopened Desk - Page is now gone from Archive on Desktop, but still not showing on Dashboard neither on Android nor Desktop
    1. Page is “gone”

Hope it can be reproduced. Object Diagnostics attached.

Yesterdays Versions: Android 0.1.11 / Desktop 0.18.15

sync-2021-06-09t08-01-05.zip

I’m experiencing this one too. Pages are disappearing from the dashboard page and become virtually invisible through all the app.

They are also available through the export results.

The only working way to retrieve it back on dashboard for me was to do a full re-sync by reinstalling the app.

I’m experiencing the disappearing pages as well.

In addition, pages seem to get duplicated when syncing and moving in and out of the archive. Multiple copies of the same page show up. They seem to be linked together; edits to one copy affects all others, and moving the page into and out of the archive moves all the copies. Not sure how exactly to reproduce this:

duplicate pages

I see differences in the title, e.g. the character missing when syncing between Desktop and Android. When changing the title again on Android after some tries it seems to sync fine.