Page on dashboard bugged (in favorites)

Describe the bug

Somehow I added and half deleted a pages and now it’s tile on the dashboard is empty and bugged. I cannot open the page, nor can I remove it from favorites. It is also in the recent page. See this screenshot:

Edit: It is the first tile on the left.

To Reproduce

Steps to reproduce the behavior:

I dont know how I created this bugged page. I think it has something to do with trying to delete it when an option to delete a page was there for me?

Expected behavior

I either expected to delete the page or to be able to remove it from favorites.

Desktop (please complete the following information):

  • OS: Windows 10
  • Version: 0.18.59

Additional context

It’s been on my favorites for a long time, way before version 0.18.59

Also I cannot find this page in the Set Drafts.

1 Like

Happens the same for me as well. And when I click that page in the inbox, it returns me to the dashboard.

@Jeroen @Kite HI! Does it reproduce in the current Anytype version?

@Kirill_Lem Hello! I can’t reproduce this error on a new page, but I still have this broken page on the favourites tab and in the inbox

@Kirill_Lem Yes is does, a week ago I got myself a new laptop and ofcourse (one of) the first things I installed was Anytype. Sadly I now have more of those blocks in my favorite (3 in total).

So I think it has to do with the sync not working properly or something. I cannot remove these tiles (can move them around but can’t right click it or open the pages)

Talking about sync, I think it does not work properly, not all pages from my old PC are on my new laptop, but I have to confirm this first and shall make a new topic about it.

For now, yes, these broken tiles/pages are still in my Anytype and cannot be removed!

@Jeroen Happens to me as well on fresh installation, it takes several tries to completely sync everything. Having anytype open in another device and making changes in while the new device is synching sometimes help, but mostly opening anytype, keeping it open for few minutes, closing and repeating the same few times syncs most pages. Few which does not, syncs in the next day or two. However this is not specific to favorites tab for me, but rather page dependent. If an yet to sync page is already a favorite and a draft type, the sync card appears in both Inbox tab and favorites tab for me

@lynxlove I know, but it has been more then a week of daily opening Anytype so the pages will stay blank in the favorites tab. Ones I have both open I will check if all the pages are synced or not but this problem is currently not fixed. Not for me at least :frowning:

This is a high priority internally and will be resolved, soon I think. :slightly_smiling_face:

2 Likes

Great to hear and that is why we are testing the alpha. :wink:

For me it is not a big issue (yet) because I am just using Anytype for testing, it is not yet my daily driver for note taking, personal wiki and more. This is the reason why I haven’t requested a fresh workspace, this is my test space so I hope to give as much information as I can (with bugs or suggestions).

Not for me, besides it happen on the Recent folder on my side.

Hopefully this will help to identify the cause.

@Kirill_Lem I see this has the tag solved, any status update on which version this is solved and/or how to fix it?

Currently at version 0.20.9 the bugged/not synced pages are still there. Even my most important page is gone at one of my PC’s … Can’t acces it from the favorites page nor can I find it via the search.

Edit:

So I did a fresh instal of Anytype today and syncing seems better, the page above is now getting synced.

Though the original page are still bugged and display a blanc tile that you cannot remove (since the three-dot menu is not present).

When I logged in the first time after the re-install I got an error message:

So after a fresh instal the sync problem is partly fixed it seems. :slight_smile:

@Jeroen You need to quit the app totally and re-open it again, it will solve this thread in use issue. Then if not solved a reinstall can be done.

The sync speed is slowed down from database update. This was never an issue prior to actual database release.Maybe this could be tracked separately. @div3xi

Yeah, that fixes that error. Now I hope to get some info about the sync problem, since a re-instal fixed it partly. I still have blanc bugged tiles and they tagged this issue as solved

@Jeroen If ayou have access to android try to open it on android?

If you can open them completely fine? sync desktop with Android app opened on the foreground. Make sure they are in same wifi.

Nope, it is also present on my android sadly.

@Jeroen there should be a thread on how to report sync issues. Follow that.

1 Like

@Srinath Yes, I have also done that, thanks for pointing it out :smiley:

1 Like

Can an admin or someone from anytype explain to me why this is tagged as solved while it still isn’t?

I still have broken page in my favorites on each PC or phone I test this, including fresh installations.

Or is this a relic from the past and the only way te remove it is a totally new login?

On windows 10:
image

On android:

@Jeroen I have removed the solved tag.

Thanks for the reply’s!

With the latest update (desktop 0.21.1) I could still not open that page, but I could remove and delete it. So now it is gone.

I think that bugged page was a relic from the past since no new ones have ever been created since I opened this topic. It also synced with my mobile where that bugged page is now also gone.

So I think now it is solved, or at least for my the problem is gone.

1 Like