P.S.A. BACKUP your data before upgrading! 0.29.9-beta upgrade lost pages/set views

WHAT IS THE BUG

After upgrading to 0.29.9-beta I lost images, pages and set view! So make sure you backup your notes or use your secudairy accounts!

HOW TO REPRODUCE IT

  1. Update to 0.29.9-beta

THE EXPECTED BEHAVIOR

Not to loose pages, notes and set views.

SYSTEM INFORMATIONS

  • OS:
    Windows 10
  • Anytype Version:
    0.29.9-beta

ADDITIONAL CONTEXT

This is an early build of the newest update and with the huge changes it was expected to happen. This is both a warning and a bug report.

Pages lost are not found in the type list, search or bin.

2 Likes

@Jeroen I had this issue directly after updating, suggesting I also lost Objects:

But, after a while of loading spinners and restarting Anytype, I don’t think I’m missing any Objects… Did you give Anytype some time to complete the migration in the background? At least, that’s what I suspect is what’s happening in the background after the update installation is completed. Something like: Anytype client software is updated and running fine, but the data was not fully migrated yet, so Objects still pending migration are not showing yet.

For now, nope. I am still missing pages and set views. I don’t see any spinning spinners other then the Graph view, which takes 30 too 60 seconds to load (might post a bug report on that as well).

Will try again this weekend though.

My Graph view also takes a long time, so I can confirm that issue (I’ll upvote your topic once posted :slight_smile: )

1 Like

Hey, Jeroen!
Thanks for reporting. It sounds like a critical issue. We can do several things in order to resolve this.

  • Can you please send as the Account Debug data (File - Account Debug)
  • Can you find the link to this missing object somewhere in other objects?
  • If yes can you use the Debug-DevTools to check the ID of this broken object link?

1 Like

@requilence Which file do you need? The debug-sync JSON file?

Is there any other way to get the Debug?

Nope, it was part of a set and has completely disappeared. To be fair, it is the same page that I have had many issues with loosing images all the time hehe.

EDIT: The set views are all back as of Version: 0.29.10-beta but the Image Set is still totally empty while not every image is gone.

2 Likes

I would like to report that as of Anytype 0.30.0 the missing pages, including the images have returned :tada:

All I did was update Anytype, so this topic can be closed in my opinion.

3 Likes