Object's page does not update real-time after clicking the said object from graphview

Describe the bug

Object’s page does not update real-time, which means:

  • Pressing “Enter” to create a new a new line won’t work.
  • Opening yellow plus sign (+) menu opens the UI popup in the top-left of the page. (If UI pop-up is not visible, you can scroll to the top to find it)
  • Highlighting then Formating (bold, “switch style”, color, etc.) won’t work.

On the good side:

  • Typing still works.
  • It updates when you leave and open the object again.

To Reproduce

  1. Open the page “A” in fullscreen.
  2. Open graphview from the top-left corner.
  3. Click object “A” from the graphview
  4. Click outside graphview window to go back to the page “A”.
  5. See bug.

Expected behavior

After leaving window (from graphview), the page should function as usual in real-time.

The pop-up menu of the yellow plus sign should appear beside the new block.

System Information:

  • OS: Microsoft Windows 10 Home Single Language
  • Device Manufacturer/Model: Acer Aspire VX5-591G
  • Anytype Version: 0.20.9

Additional context

@WhereisJ9 HI! Looks loke we have fixed it, check in the latest version

Hey @Kirill_Lem I tried it again, but the bug still persist in the current version (Anytype 0.21.1).

@WhereisJ9 I understood how to reproduce it, and add it to the bug tracker. Thank you for you notice

1 Like

Thank you too for reminding the users on whenever the bug got fixed! :grinning_face_with_smiling_eyes:

1 Like

@WhereisJ9
I followed your video and it seems to be fixed in the current release. Can you confirm that?

2 Likes

I tried to reproduce the bug, and you’re right. It’s fixed in the current release (0.25.0).
Thanks Flip! I’ll mark this post as solved.