Object Type Selector appearing even when an object type is already selected

Describe the bug
After creating an object and selecting the object type, I can go back to the main menu, select it and I’ll be presented with a huge panel at the start of the page asking me which object type will I use.

To Reproduce
Steps to reproduce the behavior:

  1. Create an object from the “+” button.
  2. Select object type
  3. Fill it with stuff
  4. Go back to main menu
  5. Select the object you just created in history
  6. It will ask you to set a type again.

This set of actions are the ones that got me to that bug several times, but it is not consistent.

Expected behavior
The type is already set so this should not appear.

System Information:

  • OS: Windows 11
  • Device Manufacturer/Model: Custom Build
  • Anytype Version: 0.20.9

I reproduced your steps, but the problem does not appear.
I’m still on Windows 10, so we would need to get more feedback from Windows 11 users, but I find it strange that this could be the cause.

Truth is, it is not very consistent, but it has happened to me several times. If I manage to discover the exact steps to get it I’ll update the post, but that’s what I did the last time it happened.

Ok, so please edit your initial description to add this important information. :wink:

1 Like

@JuanVick Looks like it was fixed. Please, check in the newest release

1 Like

@JuanVick Since there was no futher interaction, I assume this was fixed. Otherwise please let us knoe.