Object titles & descriptions truncated

Describe the bug

On the Android home page, the titles and descriptions of my page objects are missing their last character

To Reproduce

I haven’t been able to consistently reproduce this behavior. Here’s what I experienced:

    1. I was using Anytype desktop 0.18.28 on macOS Big Sur, and adding/editing pages there
    1. After not using the Android version for a few days, I installed the latest update and launched it
    1. On the home page, the pages and their descriptions were missing their last letter (see screenshots)
    1. However, when trying to reproduce this with new pages, I couldn’t get it to consistently reproduce, and eventually the existing pages started displaying correctly

Expected behavior

Titles and descriptions are shown in their entirety on Android, consistent with how they appear on desktop

Desktop (please complete the following information):

  • OS: Android 9 (Lineage build)
  • Device: Samsung SM-T710 Tablet
  • Version: 0.1.14 (114)

Additional context

Screenshots:

vs

6 Likes

I face the same issue. Shared screen recordings of the issue to the devs through telegram

1 Like

@trellick Yeah facing the same issue

1 Like

Same problem for me, random titles lose 1-3 letters at the end in the preview but not always when actually on the page

All my pages don’t keep the new name I give them. Plus I can’t move pages or blocks into other pages anymore. Everything is kind of freeze :frowning:

To reproduce:

  • Rename a page
  • See later if the name is still there

Since Android Alpha 0.1.13 Version

1 Like

Describe the bug

Page title (and some texts) not synced correctly between Desktop and Android.

To Reproduce

Steps to reproduce the behavior:

    1. Create a new page in the Desktop app with the title “My Page”
    1. Add to Favorites.
    1. Let it sync with the Android app.
    1. In an Android it shows on the dashboard as “My Pag”, so the last “e” is missing.
    1. When I go into the page it showed “My Pag”, too.

After a while it synced correctly and showed “My Page”.

Then I closed the Android app (the process), started it again and the main page showed “My Pag”. When entering the page it showed “My Page” correctly and when going back it also was correct.

Another app restart shows the same behavior. It seems “My Pag” is cached somewhere.

    1. Now I renamed the page on the Desktop to “A Renamed Page”.
    1. After syncing in Android it shows as “A Renamed Pag”.
    1. I go into the page and see the same (with the “e” missing).
    1. This time also a restart of the Android app could not bring the “e” back.
    1. I renamed the page in Android to “A New Renamed Page”.
    1. It shows in the Desktop as “A New Renamed Page” correctly.
    1. I stopped and restarted the Android app again and it shows as “A Renamed Pag”, i.e. the “New” and the “e” are missing.
    1. I keep the pages open on Android and Desktop and added text and changed the title and sync worked just fine and super fast.

Expected behavior

Title should be the same on Android and Desktop after syncing.

Environment

Desktop:

OS: Windows 10

Version: 018:28

Android:

OS: Android 12, beta 2

Device: Pixel 5

Version: 0.1.14-alpha

PS: If you should need any further information just let me know. I very new to Anytype and I am super impressed :wink:

6 Likes

I have the same problem:

Same problem here since the last update !

I’ve also noticed that on some pages it doesn’t even seem to be a sync problem between android and Windows, you have some titles that are truncated while looking at their link but that look fine when on the page on windows alone.

@trellick @Inkqb Thank you for your notice! It has been added to the bug tracker

Yeah, it might be a rendering problem.

1 Like

@XxxBalCion Hi! I can’t reproduce it in 0.1.14. Сan I ask you to record a video with this issue?

2 Likes

@Kirill_Lem the “rename” pages keeping old name" part" of this report affects me too.

I’ve already reported it and recorded videos - available here https://community.anytype.io/d/480-duplicate-a-page-then-edit-new-page-original-page-also-changes

2 Likes

Same problem here, syncing with the Linux desktop version.

1 Like

@roncz Hi! It’s the copy of https://community.anytype.io/t/-/1336. I had added this in the bug tracker.

The title does not gets updated but the page area gets updated near instant. Hope this gets fixed.

I founded the same error on 0.18.28, desktop version. Pages can be renamed but when i exit in the dashboard i see always the first name in the box.

1 Like

I’ve seen this too once or twice, I thought it was a synch problem

Describe the bug

Object title doesn’t update on the home screen.

https://imgur.com/a/VkS76ax

Steps to reproduce the behavior

Create a new page in the Desktop app - don’t edit the title, let it be “Untitled”

Add to Favorites.

Open the page, insert some stuff and any title

Go back to home and see it continues to be called “Untitled”

Expected behavior

Title should be updated when you get back to home after editing it in the page.

Environment

Desktop:

OS: Windows 10 Pro 21H1

OS Build: 19043.1110

1 Like

Hi Andre I tried to recreate the issue on my laptop but I was unable to do so. The title gets updated for me immediately. I have attached the video and my system specs. Could you attach the diagnostics if this a recurring issue.2021-07-15-01-08-32.mp4

1 Like

Ah, OK and thanks a lot @Kirill_Lem.