Not working on arch linux install

When I go to authenticate using seed phrase exported from mac it returns
“No accounts have been found”

In the linux terminal I get

{"level":"error","ts":"2023-03-08T23:23:12.624+1100","logger":"anytype-mw-api","caller":"core/account.go:462","msg":"remote profiles request failed: rpc error: code = Unavailable desc = connection error: desc = \"transport: Error while dialing dial tcp: lookup cafe1.anytype.io: Try again\""}

SYSTEM INFORMATION

  • OS:
    ᅟArch Linux with wayland/hyprland
  • Device:
    Macbook pro 2019
  • Anytype Version:
    0.31

Hi @garthtrickett, the error seems to hint at a connection error. Are you sure there isn’t anything blocking traffic between the application and the public internet?

1 Like

There could be, ive tried with both an .AppImage and converted deb and I get the same error

@garthtrickett

Are you accessing the internet with a VPN or on a unique network configuration, such as school or work?

If so, try disabling your VPN, use another connection, or use your mobile device as a hotspot (just to log in).

I’ve tried from my hotspot with and without a vpn. Also from uni network with vpn with same results.
Even though I get this error in the terminal that was used to start anytype
transport: Error while dialing dial tcp: lookup cafe1.anytype.io:

Immediately after shutting anytype I am able to ping cafe1.anytype.io from that same terminal instance no problem

I loaded up macos partition and installed anytype. Didn’t have an issue with the seed prase login. Seems the issue is specific to linux.

1 Like

I tried getting an rpm and using a script to convert it into something that pacman can install on arch. I was able to load the app via this method but again I get the same error. It seems the problem is not something specific to .appimages.

Bump

This report has been added to our issue tracker and received by the Development Team.

I managed to get it working using wine and the windows .exe but still not ideal.

1 Like

That’s cool. I didn’t know Wine was still maintained.

Hey there, I just downloaded and installed Anytype-0.31.0.AppImage. It opened on first run, and seemed to be working. I created an account but it wasn’t syncing. Sync seems to work after opening and closing it 3 times.

6.2.7-arch1-1 kernel, i7-12700K x86_64 CPU

1 Like

I dunno whats changed but its working now

1 Like

Hi @jennydaman welcome to the Community!

Thanks for sharing your solution :slight_smile: Maybe it can work for others as well.


@garthtrickett nice to hear that. Always nice when problems solve themselves, wish it was always that way!

Anyway, this should no longer be a problem with the new Anysync infrastructure.

1 Like