Not possible to indent lists on iOS


it’s not possible to indent a list inside another list:


Outline the steps needed to reproduce the behavior in sequence:


  1. Go to Anytype app
  2. Add a note
  3. Add text
  4. Add the style of unorganised list
  5. ᅟAdd another line with text
  6. Try to make the line below indented


*only possible to have indented lists in the desktop *


it is possible to have unorganised and organised lists indented in desktop, iOS, and Android



  • Device:
    iPhone 12 mini
  • OS:
    iOS 16.6
  • Anytype Version:

Can you try using drag and drop to indent lines on iOS?

I’m curious, what ways did you try to indent it to a deeper level?
What gesture or mechanic did you expect?

As @isle9 implied - it’s possible using drag and drop or the “move” option of the block. But that’s not very intuitive to me.

Personally I really like the way e.g. Logseq has this implemented. A swipe to the right indents the block one level deeper, a swipe to the left reduces one level of indentation. But Logseq is an outliner so it’s a core feature I guess. Don’t know how hard this would be to implement for anytype. And this would more likely be an enhancement than a bug fix :bug:

1 Like

Drag and drop:
I have already tried in my iPhone 12 mini. No results. I can only move it vertically. The same with the move command, I am Ily able to move it vertically.

I like a lot what Slack does

No problem on my iPad mini nor iPhone 11 :thinking: with Drag and Drop .

One thing I noticed from your screenshot though:
Do you use external keyboard application? The green enter arrow doesn’t look like Apple’s original keyboard. ← I don’t see such indentation option with my system default keyboard :face_with_monocle:

P.S. I would be great if we can have indentation at style selection and / menu.

I guess, that’s from the applications toolbar, just like Anytype has a toolbar sitting right above the keyboard.

Just in case that’s not clear: you need to drop it “on” the item where you want the selected item to be nested in. Let go, when the block is highlighted, not when there’s just a vertical bar visible. If that’s not working maybe a screencast may be helpful.

1 Like

That drag and drop on top of the item finally worked. Wow, finally!!

Nice feature request would be to have the indent option in the toolbar as Slack does.

Thank you for all your help!!

What I don’t see is that I can change the organised list from 1,2,3,n to a,b,c,z

1 Like

This topic was automatically closed after 6 days. New replies are no longer allowed.