Non-existing object stuck in Favorites

WHAT IS THE BUG

I was having some issues with synchronization related to the issue in the post below. After a reinstallation of Anytype, a non-existent object has been tagged as a favorite on the home screen’s Favorites page.
The item seems to be synchronizing, but there is nothing to sync.

Anytype sync error

I am unable to remove the object. I tried reinstalling the program and removing the working directory.

The object did not appear in the Android app, but when I reinstalled it to test, a new object titled: “Untitled” appeared, of type: “set” and when I tried to open it, I received the error message: “This object doesn’t exist.”

HOW TO REPRODUCE IT

  1. Reinstalled Anytype.
  2. Non-existent object has been tagged as a favorite on the home screen’s Favorites page.

THE EXPECTED BEHAVIOR

A non-existent object should not be generated and labeled as a Favorite at random.

SYSTEM INFORMATIONS

  • OS:
    Windows 11 Pro
  • Device:
    Desktop
  • Anytype Version:
    0.28.0

ADDITIONAL CONTEXT

I’m thinking this is connected to the sync problem that was mentioned on the forum a few days ago.

1 Like

Thanks for reporting on this phenomenon of ghost objects. I have them too, as well as others. I can’t say with 100% certainty, but my understanding is that this occurs when an object isn’t fully synced and before it has had a chance to successfully do so, is either deleted and/or a migration to another device was initiated. Then possibly after fiddling with it, the change logs are overwritten and the object is trapped in limbo.

Unfortunately for now, we don’t have an innate solution to expel them. We could attempt a quick fix with you, and try to debug it at some point, or you can create a new profile.

1 Like

Thank you for the quick reply.
How would I go about creating a new profile?

You can ask @Angelo or email to support@anytype.io :slight_smile:

1 Like

Check your inbox @Cernel1337 :wink:

1 Like

Thank you very much for your prompt assistance.
Please let me know if the team needs anything in terms of debugging the previous account.

1 Like